--> Gourmet and Intrepid

  • Alex Carlos

    Alex Carlos - 2008-10-17

    Hello all,

        First I'd like to congratulate all for this wonderful program !

        I installed it on a Hardy Heron and it works perfectly, but on my notebook that has Intrepid (with last updates) installed, I have some problems...

        I installed the .deb 0.13.4. When I import an recipe from a web page (general page), it opens the importer for me to select the portions of the recipe. After I finish the process, the recipe is imported, but the ingredients are not imported correctly. Only the first one is imported. the rest is lost.

        If I edit the recipe to add the other ingredients, I get the following error on terminal:

    Failed to execute:
    sql   :  INSERT INTO categories(category, id) VALUES (?, ?)
    params:  ['', 10]
    Traceback (most recent call last):
      File "/usr/share/gourmet/reccard.py", line 583, in saveEditsCB
        self.current_rec = self.rg.rd.modify_rec(self.current_rec,newdict)
      File "/usr/share/gourmet/backends/rdatabase.py", line 514, in modify_rec
      File "/usr/share/gourmet/backends/sql_db.py", line 371, in do_add_cat
      File "/usr/share/gourmet/backends/sql_db.py", line 344, in do_add
      File "/usr/share/gourmet/backends/sql_db.py", line 101, in execute
    pysqlite2.dbapi2.IntegrityError: PRIMARY KEY must be unique

    I also tried 0.14.0 that comes in the repositories, but I cannot get it to work on importing, I get another error...

    Any help would be apreciated....
    thanks !!!

    • mumcs01

      mumcs01 - 2008-10-17

      Interesting. I've had problems as well with the webpage import feature as well, though a little different. When I do an import I get an error following the import saying it was unsuccessful, however if I restart the application, the receipe is actually there.

      • Alex Carlos

        Alex Carlos - 2008-10-17

        I removed my ~/.gourmet directory and it is working now. Started importing and it is working now.

        I backed up my previous recipes, but I'll not try to bring them back.

        I don't know what happened, maybe some confusion with the version changes. Even purging the data...

        But anyway, it is working now... thanks a lot...

    • ken schutter

      ken schutter - 2008-11-23

      I have installed Intrepid and all updates.  Installed Gourmet and then tried to import my recipes saved from Hardy and after import, there is nothing shown.  Hope help is on the way.

    • Thomas Wetherbee

      I am a little puzzled about the bug reporting process. I reported a printing problem with Intrepid and the current Intrepid Gourmet package, but the bug report was removed with the resolution of being "Out of date". What does this mean, and why is a bug report removed without any trace. If there was an existing report saying that the problem is fixed for the next release, then I wouldn't have posted my bug. As it is, I'm not sure how a user would know that the problem was already known.

      It looks like there are a bunch of issues with Intrepid and Gourmet. I hope they get resolved, as I like this program very much.


      • tom

        tom - 2008-11-26

        The bug was not removed, just closed. It's a bit annoying, but the default "search" is set to filter for status:open -- you need to change that combobox to status:any to search all bugs and prevent dups.

        The SF bug tracker is for the packages I release. Bugs for 0.14.0 are out of date -- the unstable branch (which is what 0.14.0 is part of) has moved on since then. The whole point of the unstable branch is to get things out there quickly, so I don't want to spend time fixing bugs for 0.14.0 that have already been fixed in e.g. 0.14.2 (that's what the stable branch is for).

        It is frustrating that such an unstable release of gourmet got packaged for intrepid. It's also frustrating that I haven't been able to get a new version released that at least fixes the very bad bug that destroys user data (https://bugs.launchpad.net/ubuntu/+source/gourmet/+bug/291353).

        I recommend installing the source packages from SF for the time being and not using the Intrepid packages.

    • Thomas Wetherbee

      Okay, that all makes sense. I manually pulled down the new version and printing now works. I had foolishly assumed that the version included with Ubuntu would be the stable version.

      I need to rant for a moment. I don't know who the knuckle heads were that decided to roll up an unstable version with the Ubuntu update, but they should be tarred and feathered. This mistake has cost me a lot of good recipes due to the database problem. I thought I had a backup copy, but the subtle nature of just deleting ingredients means that I rippled the bad data through my backups and now I'm SOL. If I decide to keep using Gourmet, you can bet I will now keep backups up the wazoo. This sort of poor project management doesn't help the open source movement.


      • tom

        tom - 2008-12-07

        I hear you. This is a side effect of Ubuntu's strict update policy. I think a lot of fringe projects get hurt in this way. I know a while ago I was interested in trying out glom, which is under pretty active development. The result of using the ubuntu package was that I got a very unstable glom and when I went to report problems, I realized they were all already fixed in the development version.

        Gourmet's bug is very bad because it destroys data. What is frustrating is that I fixed the bug within a day or two, so the number of users affected should have been *very* small. But I'm afraid I'm going to keep hearing about this bug for weeks and weeks to come.

    • BobSongs

      BobSongs - 2009-03-25

      I worked my way through Synaptic, installing all the libraries I could.

      I deleted the .gourmet folder in my home directory.

      When I first started version 13.5.x on Intrepid Ibex, I got this warning:

      Traceback (most recent call last):
        File "/usr/bin/gourmet", line 34, in <module>
          import gourmet.GourmetRecipeManager
        File "/usr/lib/python2.5/site-packages/gourmet/GourmetRecipeManager.py", line 5, in <module>
        File "/usr/lib/python2.5/site-packages/gourmet/batchEditor.py", line 4, in <module>
        File "/usr/lib/python2.5/site-packages/gourmet/ratingWidget.py", line 144, in <module>
        File "/usr/lib/python2.5/site-packages/gourmet/ratingWidget.py", line 45, in __init__
        File "/usr/lib/python2.5/site-packages/PIL/Image.py", line 1889, in open
          fp = __builtin__.open(fp, "rb")
      IOError: [Errno 13] Permission denied: '/usr/share/gourmet/gold_star.png'

      The last line was interesting. a locked png file. So I tried Gourmet in super user mode (gksudo gourmet), and it was encouraging to see the software start up. To fix the solution, I issued this command:

      sudo chmod 777 -R /usr/share/gourmet/*

      Gourmet ran after this. The software produced this minor error. But any ideas on how this can be corrected would be appreciated. The output:

      Using sqlite3
      Player is  gourmet.sound_gnome.Player
      /usr/lib/python2.5/site-packages/gourmet/prefsGui.py:56: GtkWarning: GtkSpinButton: setting an adjustment with non-zero page size is deprecated

      ** (gourmet:2833): WARNING **: expected enumeration type PangoWrapMode, but got GtkWrapMode instead

      The last line is repeated several  times.



Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:

No, thanks