Updating Error Ubuntu Edgy Eft

Help
Syrra
2006-12-26
2013-05-14
  • Syrra

    Syrra - 2006-12-26

    Now, I'm a bit of a newbie at Linux, but Ubuntu usually doesn't mess me up. Now, however, I have a problem.

    I've previously installed a version of Gourmet (12.1 or 12.2) using the .deb and then downloaded and installed the new version, also using .deb. (I had meant to export my recipes beforehand, but I got ahead of myself.) The package installer didn't give me any errors and there doesn't seem to be two versions installed. After running the program from the menu, I get this error:

    Database Connection failed.

    Traceback (most recent call last):
      File "/usr/share/gourmet/GourmetRecipeManager.py", line 442, in init_recipes
        self.rd = recipeManager.RecipeManager(**recipeManager.dbargs)
      File "/usr/share/gourmet/backends/sqlite_db.py", line 81, in __init__
        RecData.__init__(self,filename=file)
      File "/usr/share/gourmet/backends/sqlite_db.py", line 21, in __init__
        rdatabase.RecData.__init__(self)
      File "/usr/share/gourmet/backends/rdatabase.py", line 175, in __init__
        self.setup_tables()
      File "/usr/share/gourmet/backends/rdatabase.py", line 225, in setup_tables
        self.update_version_info(gourmet.version.version)
      File "/usr/share/gourmet/backends/rdatabase.py", line 307, in update_version_info
        {'link':rec_url,
    UnboundLocalError: local variable 'new_source' referenced before assignment

    IF there is a way to fix it, that would be good. I have had some small amount of programming experience, though not much with python, but I'm capable of editing and compiling files. I've got a backup of recipes.db on my desktop, so if just un- and reinstalling and putting this file in the directory would work that would be good too.  Otherwise, I'll just uninstall and reenter all the recipes. Thanks for the help.

     
    • Syrra

      Syrra - 2006-12-27

      Hmmm, I uninstalled and reinstalled 13 and it threw the same error. So I tried dpkg -P and it still did the same thing. I have now installed 12.2 and it works. And managed to find my recipe files(!), which I have now exported as XML and plaintext. 

       
    • tom

      tom - 2006-12-28

      You found a bug -- thanks for the report! I just fixed this in CVS. I'll release the fix shortly.

       

Log in to post a comment.