Anyone got this running on OS X?

Help
dandam
2005-09-02
2013-05-14
  • dandam

    dandam - 2005-09-02

    Does anyone have a working version of this working in OS X? What do I need to do in order to install and run this?

    Thanks,
    -Dan

     
    • tom

      tom - 2005-09-02

      I don't know of anyone who has run Gourmet on OSX.

      I would love to get it going though. It probably makes the most sense for someone familiar with fink to work on this. It certainly should be possible. Here's the link to the fink project:
      http://fink.sourceforge.net/index.php?phpLang=en

      It would also require compiling metakit for OSX -- there may be a compiled version already in existence.

      It looks like via fink you can request a package -- so you might add Gourmet and see if anyone picks it up. If you've got some time to put in, I could also give whatever support possible to help you get it working -- it would be great to get a package for OSX.

      The steps would be something like....

      1. install python, python imaging library (PIL)
      2. install pygtk/python-gnome
      3. Get a simple pygtk app to run (another app or a hello world I could send you)
      4. get metakit and python bindings form metakit working
      5. get gourmet working
      6. Publish instructions or, better yet, create a fink package.

      If you or anyone else does all this, please take good notes as you do it for future reference!

       
    • Moon47usaco

      Moon47usaco - 2005-09-04

      I have just started fooling with Fedora and it has given me a somewhat better understanding of the command line terminal...

      I would like to tackle this... Or at least attempt...

      If anyone could post links here to where i can get started...

      Python, gnome, metakit... ??
      Thanks
         R

       
      • tom

        tom - 2005-09-04

        I don't know much about the fink project, but it looks like you could get the pygtk stuff pretty easily via packages on their website:

        pygtk2-python
        gnome-python
        pil

        I assume their packages have a way to handle dependencies so that you will get everything at once.

        Searching for metakit OSX with google gets me the following via darwinports:
        http://metakit.darwinports.com/

        If you have some experience with fink or darwinports, you probably know what this means more than I do. If not, I assume that these are packaging systems (like apt-get or rpm?) designed to bring *nix-based software to the mac.

         
    • Elia Cohen

      Elia Cohen - 2005-09-09

      Hi,

      I have been attempting to get this to work on my Mac without any luck.  I tried with Fink and by installing pygtk from Darwinports.  Either way, I still get the same error:

      ----------------------------------------------------------------
      running build_py
      running build_scripts
      running install_modules_check
      Error: PyGTK-2.3.93 or newer is required.
      ----------------------------------------------------------------

      I would love to get this to work on my Mac so if anyone has any more tips for this, please let me know.

      Thanks,

      -E

       
      • tom

        tom - 2005-09-09

        Can you confirm what version of pygtk you installed?

        You could see what got installed by running the following:

        $ python
        >>> import gtk
        >>> print gtk.gtk_version, gtk.pygtk_version
        (that will print the version)
        (then press C-d to exit).

        btw, if you want to give this a go, it may be easiest to chat -- my AOL/jabber.org screenname is blackmaps, or you can chat with me via google chat if that works for you (tmhinkle).

         
    • Jim

      Jim - 2005-09-29

      I wanted to let you know that Kim Komando has recommended this program on her website, www.komando.com, under Best Shareware Picks and it dosen't work for Mac OS X Tiger 10.4.2.
      Any sugestions?

       
      • tom

        tom - 2005-09-29

        I don't know what she was thinking when she wrote that the OSX version was the tarball. It's true that that's where you'd start to get this working on OSX, and it should be doable quite easily -- anyone who's run any other GNOME software on OSX could probably get Gourmet up in a jiffy. That said, no one's done so yet that I know of.

         
      • tom

        tom - 2005-10-06

        Looks like good news is on the way for OSX folks:
        http://micke.hallendal.net/archives/2005/10/gtk-macosx.html
        It's only a matter of time until they get it done.
        Hopefully this will allow us to do the right thing and run Gourmet natively on OSX.

         
    • Elia Cohen

      Elia Cohen - 2005-09-29

      The biggest problem I have encountered was finding the right py-GTK version for OS X and getting that installed.  I have not been successful at doing this with either Darwinports or Fink since both of them have an older, not compatible version of py-GTK.

       
      • dandam

        dandam - 2005-10-05

        Have you seen this?

        http://py-gtk2.darwinports.com/

        It appears to be for version 2.8.0

         
    • dandam

      dandam - 2005-10-05

      I also tried to manually install pygtk using the instructions here: http://apnaopus.var.cc/wiki/index.php/ApnaOpus_on_OSX

      But failed when I tried to install gettext-0.14.1. ./configure worked fine, but make resulted in the following errors:

      Making all in autoconf-lib-link
      Making all in m4
      make[2]: Nothing to be done for `all'.
      Making all in tests
      make[2]: Nothing to be done for `all'.
      make[2]: Nothing to be done for `all-am'.
      Making all in gettext-runtime
      make  all-recursive
      Making all in doc
      make[3]: Nothing to be done for `all'.
      Making all in intl
      /bin/sh ../libtool --mode=link \   gcc  -g -O2   -o libintl.la \   bindtextdom.lo dcgettext.lo dgettext.lo gettext.lo finddomain.lo loadmsgcat.lo localealias.lo textdomain.lo l10nflist.lo explodename.lo dcigettext.lo dcngettext.lo dngettext.lo ngettext.lo plural.lo plural-exp.lo localcharset.lo relocatable.lo localename.lo log.lo printf.lo osdep.lo intl-compat.lo -liconv  -lc \   -version-info 7:0:4 \   -rpath /usr/local/lib \   -no-undefined
      gcc -dynamiclib  -o .libs/libintl.3.4.0.dylib  .libs/bindtextdom.o .libs/dcgettext.o .libs/dgettext.o .libs/gettext.o .libs/finddomain.o .libs/loadmsgcat.o .libs/localealias.o .libs/textdomain.o .libs/l10nflist.o .libs/explodename.o .libs/dcigettext.o .libs/dcngettext.o .libs/dngettext.o .libs/ngettext.o .libs/plural.o .libs/plural-exp.o .libs/localcharset.o .libs/relocatable.o .libs/localename.o .libs/log.o .libs/printf.o .libs/osdep.o .libs/intl-compat.o  /usr/lib/libiconv.dylib -lc -install_name  /usr/local/lib/libintl.3.dylib -compatibility_version 8 -current_version 8.0
      /usr/bin/libtool: for architecture: cputype (16777234) cpusubtype (0) file: -lc is not an object file (not allowed in a library)
      /usr/bin/libtool: for architecture: cputype (16777234) cpusubtype (0) file: -lSystem is not an object file (not allowed in a library)
      make[3]: *** [libintl.la] Error 1
      make[2]: *** [all-recursive] Error 1
      make[1]: *** [all] Error 2
      make: *** [all-recursive] Error 1

       

Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:

JavaScript is required for this form.





No, thanks