Ubuntu: Nutritional Edit does not work

  • Alex Carlos

    Alex Carlos - 2008-10-20


       I am trying to open the nutritional information on a recipe, but when I click on the EDIT button, nothing happens, and I get this error on the console:

    Traceback (most recent call last):
      File "/usr/share/gourmet/reccard.py", line 175, in <lambda>
        'edit_nutrition': lambda *args: self.nutritionLabel.show_druid(nd=self.nd),
      File "/usr/share/gourmet/nutrition/nutritionLabel.py", line 478, in show_druid
      File "/usr/share/gourmet/nutrition/nutritionDruid.py", line 273, in __init__
      File "/usr/share/gourmet/nutrition/nutritionDruid.py", line 359, in _setup_widgets_
      File "/usr/share/gourmet/nutrition/nutritionDruid.py", line 547, in _setup_custom_box
        + defaults.UNIT_GROUPS['imperial weight']]
    KeyError: 'imperial weight'

    I am using 0.13.7. It also happens on 0.13.4.


    • tom

      tom - 2008-10-20

      This is an i18n bug. What language environment are you in?

      Regardless, if you're willing to poke around with code, you can almost surely fix it by patching the relevant defaults_XX file for your locale so that it matches the normal defaults_en_US

    • Hal Wilke

      Hal Wilke - 2008-12-31

      I am running gourmet 0.14 on Ubuntu Intrepid, and I don't even see any nutritional information, much less an edit button for it.  I'm not sure if this is the same issue as mentioned above, but am always wary of starting a new thread if a relevant one already exists.  I read the suggestion above, but do not know enough to figure out what the suggestion means.  Any help would be appreciated.


      • tom

        tom - 2008-12-31


        Nutritional information is a plugin in the 0.14.x branch. Go to Preferences -> plugins and enable it.

        FWIW, I recommend against using ubuntu's 0.14.0 package -- it's a snapshot of a development version that has a lot of known bugs in it that have already been fixed in the more up-to-date sourceforge source packages.


    • Hal Wilke

      Hal Wilke - 2008-12-31

      Thanks.  I installed the current version and the nutrition information tab appeared.  On first run it loaded all the nutrition information, which the Ubuntu version had not done.  Thanks for the help.  This is a very cool program.

    • J P

      J P - 2009-01-18

      Just to confirm that I'm reading this thread correctly-- in order to get nutritional information to work, I must update to the current version from Ubuntu's 0.14.0 version?  I am unable to figure out how to get any nutritional info with Ubuntu's version.

      I realize that sooner or later I've got to figure out how to do a software update on Ubuntu- I've only had it installed for a few days- so it would help motivate me if I was sure that nutritional info would appear after I succeeded at updating;)

      Thanks.  (And, any pointers to a 'Dummy's Guide to Ubuntu Software Updates for Windows Refugees'??

      • tom

        tom - 2009-01-18

        I don't recall if nutrition was working in 0.14.0.

        Regardless of version, nutritional info is an optional plugin in anything in the 0.14.x series or forward, so you do have to go to Preferences->Plugins and activate it.

        Have you tried this yet in the version you're using?

    • J P

      J P - 2009-01-18

      The preferences has Nutritional Information checked as 'active', so I assumed that meant the function was available.  Maybe I'm just not figuring out how to display it in a recipe?  I tried following the help file: "click "Edit" and a new window will pop up and ask you to give it the information it needs to calculate nutritional information" and clicked every 'edit' I could find anywhere in the program and nothing seemed to have any link to nutritional info?  Maybe it's my misunderstanding?

      • tom

        tom - 2009-01-18

        Nope -- it's not your fault.

        The help file is almost certainly out of date. 0.14.x is all still in the "unstable" branch here on SF, which means that it's meant to be bleeding edge -- more bugs, but more regular updates, etc. Unfortunately, Ubuntu packaged 0.14.0 and then is frozen with that version for 6 months. This means lots of people are using it who really should be using the stable branch (0.13.x).

        We will update the help file eventually, of course, but that's something that typically happens before marking the package stable.

    • J P

      J P - 2009-01-19

      I think I was successful installing 0.14.3.  Using a combination of web linux install info, the readme file, and pure guesswork I finally got down to this message:
      "error: can't copy 'gourmet.desktop': doesn't exist or not a regular file".  I then ran GRM, and it seemed to work, and I found the nutrition information.

      So, apart from that error message, things seem to be working.  Is this error anything to worry about?

      Thanks for your help.

      • tom

        tom - 2009-01-19

        The line about gourmet.desktop not being generated suggests that some of the i18n stuff is not running properly (this should compile gourmet.desktop.in into gourmet.desktop based on available translations). Not the end of the world.


Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:

No, thanks