error starting gourmet: sqlalchemy Text

Help
Merl
2009-03-12
2013-05-14
  • Merl

    Merl - 2009-03-12

    I have a brand new machine with a first time install of gourmet 0.14.7.  I am getting an error from sqlalchemy when starting gourmet.  Does anyone have any clues to give me on sorting this one out?  See full error stack below.

      File "/usr/lib/python2.4/site-packages/gourmet/backends/db.py", line 21, in ?
        from sqlalchemy import Integer, Binary, String, Float, Boolean, Numeric, Table, Column, ForeignKey, Text
    ImportError: cannot import name Text

    [My history:  I've been a happy gourmet user for months, running on my ubuntu server, displaying X back to my laptop in the kitchen... laptop is too big, so i bought on of these, tiny eee pc's (700 2G Surf) expressly as a "kitchen appliance" -- to run my gourmet, and to stream my internet radio... SO, this eee pc is running a modified xandros distro from asus.  it's debian, so i figured this would be a no brainer... but the xandros was relatively old, and had python 2.2.  i installed python 2.4 and related libs just fine.  See my installed version info below for all things python.  So, it appears to me that I have all of my dependencies met, but i'm getting this error.  I have found this error on the net ('cannot import name Text'), but very few hits (for other python apps) and no solutions.  ]

    Any help greatly appreciated!!

    Brian

    Traceback (most recent call last):
      File "/usr/bin/gourmet", line 34, in ?
        import gourmet.GourmetRecipeManager
      File "/usr/lib/python2.4/site-packages/gourmet/GourmetRecipeManager.py", line 6, in ?
        import recipeManager
      File "/usr/lib/python2.4/site-packages/gourmet/recipeManager.py", line 17, in ?
        from backends.db import *
      File "/usr/lib/python2.4/site-packages/gourmet/backends/db.py", line 21, in ?
        from sqlalchemy import Integer, Binary, String, Float, Boolean, Numeric, Table, Column, ForeignKey, Text
    ImportError: cannot import name Text

    I installed python 2.4 and related libs... most came with the base python, but i had to get the correct python-central myself, but all seemed to go well.  below is my dump from apt-show-versions for all my python and related libs:

    python2.4/etch upgradeable from 2.4.4-3 to 2.4.4-3+etch2
    python2.4-minimal/etch upgradeable from 2.4.4-3 to 2.4.4-3+etch2
    python-cairo/etch uptodate 1.2.0-1
    python-central 0.6.11 newer than version in archive
    python/etch uptodate 2.4.4-2
    python-glade2/etch uptodate 2.8.6-8
    python-gtk2/etch uptodate 2.8.6-8
    python-imaging/etch uptodate 1.1.5-11
    python-minimal/etch uptodate 2.4.4-2
    python-numeric/etch uptodate 24.2-7
    python-pysqlite2/etch uptodate 2.3.2-2
    python-qt3/etch uptodate 3.16-1.2
    python-reportlab/etch uptodate 2.0dfsg-1
    python-sip4/etch uptodate 4.4.5-4
    python-sqlalchemy/etch uptodate 0.3.1-2
    python-support/etch uptodate 0.5.6
    python-uno/etch upgradeable from 2.0.4.dfsg.2-7etch2eeepc1 to 2.0.4.dfsg.2-7etch6
    python-xml/etch uptodate 0.8.4-6

     
    • tom

      tom - 2009-03-13

      Here's your problem:

      python-sqlalchemy/etch uptodate 0.3.1-2

      Alas, sqlalchemy is a rather fast developing library... the way I did text columns before became deprecated and I think with the latest will prevent start-up... but having fixed it to use their new API, I break the code for people with older versions like yours.

      I'd go ahead and try to update to the latest sqlalchemy (0.5.x). It's likely an 0.4.x version would work as well.

       
    • Merl

      Merl - 2009-03-13

      thanks for the fast response tom.

      alas, trying to upgrade sqlalchemy puts me in dependency hell -- need  to bump python-support, which needs to bump dpkg, which needs to bump libc6... since i'm getting into system binaries, i'm weary of what other system libs i could break... or never be able to resolve, short of full os upgrade...

      maybe i can downgrade my gourmet to the version before you made your change... what version was that?  and if i downgrade gourmet, will i have problems with my db?  i have already been working on gourmet 0.14.7 on my existing ubuntu... i'm concerned if i start hitting that db with and older version of gourmet, i could trash it... depending on your backward compatibility...

      re: full os upgrade... i already tried to put eeebuntu (of course there is one) on this eee pc, and it was great (and yes, gourmet ran great), but eeebuntu is quite a bit fatter than this old xandros, consuming all but a few megs of my 2GB SSD... i installed one more app and i ran out of space... so i went back to the factory xandros... and here i am. 

      long story, but if you think it is likely my onion will continue to unravel, i will look into a puppy or dsl distro for this thing to get a more current kernel than this old xandros.... hoping they trimmed things down more than eeebuntu did.

      thanks alot tom.  i love your app!

      brian

       

Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:

JavaScript is required for this form.





No, thanks