trying to save my work/recipes

Help
Anonymous
2007-02-22
2013-05-14
  • Anonymous - 2007-02-22

    The X-server has badly blown up and I can't start the gui or load gourmet. When I try to start it at the command line, I get

    mark@Lexington:/mnt/Drive2/usr/bin$ gourmet
    /usr/share/gourmet/importers/__init__.py:3: DeprecationWarning: Non-ASCII character '\xc3' in file /usr/share/gourmet/importers/rezkonv_importer.py on line 41, but no encoding declared; see http://www.python.org/peps/pep-0263.html for details
      import gxml2_importer, rezkonv_importer
    Player is  gourmet.sound_gnome.Player

    I've had to swap harddrives temporarily and Gourmet is sitting on hdb1 (prim.-slave). Is there a way to make gourmet make the .xml and export it to the hda1?

     
    • tom

      tom - 2007-02-25

      The DeprecationWarning is normal and doesn't prevent Gourmet from starting up. If you use Control-C to kill Gourmet from the terminal, it should generate a python exception -- this will tell you what Gourmet was in the midst of doing when it started up. That might be some hint as to what the problem is.

      If you want to load your old recipes with a new installation of gourmet, all of the recipe data is inside of the ~/.gourmet/ directory -- you should be able to copy that directory to your new set-up and use it with a fresh installation of Gourmet without any problem (you can also make a backup copy of that directory as often as you like)

       
      • Anonymous - 2007-02-26

        I, being a noobie at Linux/Ubuntu went ahead trying to have Gnome do a copy from /mnt/Drive2/home/mark/.gourmet to /home/mark/.gourmet

        The first time I tried this, the Desktop "blew up" and issued a Bug Buddy request.

        The 2nd time, I did

        sudo cp /mnt/Drive2/home/mark/.gourmet to /home/mark/.gourmet

        which yielded an odd error message:

        cp: omitting directory `/mnt/Drive2/home/mark/.gourmet'

        both times, invoking Gourmet returned:

        Database Connection failed.

        There was a problem with the database information you gave Gourmet

        Traceback (most recent call last):
          File "/usr/share/gourmet/GourmetRecipeManager.py", line 442, in init_recipes
            self.rd = recipeManager.RecipeManager(**recipeManager.dbargs)
          File "/usr/share/gourmet/backends/sqlite_db.py", line 85, in __init__
            RecData.__init__(self,filename=file)
          File "/usr/share/gourmet/backends/sqlite_db.py", line 21, in __init__
            rdatabase.RecData.__init__(self)
          File "/usr/share/gourmet/backends/rdatabase.py", line 175, in __init__
            self.setup_tables()
          File "/usr/share/gourmet/backends/rdatabase.py", line 227, in setup_tables
            self.update_version_info(gourmet.version.version)
          File "/usr/share/gourmet/backends/rdatabase.py", line 320, in update_version_info
            for r in self.fetch_all(self.rview): self.update_hashes(r)
          File "/usr/share/gourmet/backends/rdatabase.py", line 560, in update_hashes
            rhash,ihash = recipeIdentifier.hash_recipe(rec,self)
          File "/usr/share/gourmet/recipeIdentifier.py", line 63, in hash_recipe
            inghash = get_ingredient_hash(rd.get_ings(rec),conv)
          File "/usr/share/gourmet/recipeIdentifier.py", line 42, in get_ingredient_hash
            ings = [standardize_ingredient(i,conv) for i in ings]
          File "/usr/share/gourmet/recipeIdentifier.py", line 37, in standardize_ingredient
            amount = round(amount,-1)
        TypeError: a float is required

        sudo cp /mnt/Drive2/home/mark/.gourmet/recipes.db to /home/mark/.gourmet/recipes.db

        returns the same problem as above. Any help greatly appreciated.

         
        • nanotube

          nanotube - 2007-02-26

          here's my guess:
          after you do the "sudo cp" you have to go in and change ownership to your username.
          so first:

          "sudo cp -R /mnt/Drive2/home/mark/.gourmet /home/mark/.gourmet"

          then

          "sudo chown -R mark:mark /home/mark/.gourmet"

          when you do a "sudo cp" the files it creates are owned by root, which may be a problem if you are running gourmet as your user, rather than root. :)

          the "-R" flag means recursive, meaning, copy (or chown) all files in that directory.

           
    • Anonymous - 2007-03-03

      By using Aptitude to uninstall and GDebi to install and immediately thereafter re-install Gourmet, everything is working fine. Thanks.

       

Log in to post a comment.