Windows feedback

  • Richard Beels

    Richard Beels - 2010-03-01

    Finally, a current windows build.  yeah!  :-)

    Using XP SP3; gourmet-0.15.4-alpha

    1. I tried the nogtk version but it errored out so I tried the full version.  It "uprgaded" my existing gt+ version from the 2.14.7 rev a that came with pidgin to what was in the installer.  the installer should recognize existing gtk installs and not downgrade current installs.

    anyway, using the gtk that gourmet installed, the following happens.

    if i run gourmet from the commandline, i get the following error in the .log:
    Traceback (most recent call last):
      File "Gourmet.pyw", line 2, in <module>
      File "zipextimporter.pyo", line 82, in load_module
      File "gtk\__init__.pyo", line 38, in <module>
      File "zipextimporter.pyo", line 82, in load_module
      File "gobject\__init__.pyo", line 30, in <module>
      File "zipextimporter.pyo", line 82, in load_module
      File "gobject\constants.pyo", line 22, in <module>
      File "zipextimporter.pyo", line 98, in load_module
    ImportError: MemoryLoadLibrary failed loading gobject\_gobject.pyd

    Debug version gets me this:
    C:\Program Files\Gourmet\
    > Gourmet_debug.exe
    Traceback (most recent call last):
      File "GourmetDebug.pyw", line 9, in <module>
      File "zipextimporter.pyo", line 98, in load_module
    ImportError: MemoryLoadLibrary failed loading win32ui.pyd

    Double-clicking the .exe in explorer and using the shortcut in the startup menu launches gourmet.exe correctly but the debug never runs (you get the quick dos box pop up and disappear before you can read the text so i assume it's the same error).

    2. When gourmet launches, the window is painted 360x170 pixels wide (if launched from the shortcut with maximized, that works) and resizing changes aren't carried over into future sessions.  Additionally, when a recipe is opened or the edit instructions buton is clicked, those windows are drawn similarly-sized and resizing isn't saved.

    3. 7-zip 4.65 opens the file; winzip 9 doesn't; WinRAR 3.90 doesn't; pkzip25.exe says:
    Viewing .ZIP: Copy of
    Errors were found in .ZIP file, attempt to fix (<Y>es/<N>o)? y
    Enter a new .ZIP file name (pkfixed):

    Running PKZipFix utility.

    Scanning .ZIP file:      Copy of
    Building new directory.
    Writing new .ZIP file:

    Recovered 681 files.

    Recovered .ZIP filename is:

    It also shrinks the size from 7,902,270 to 5,725,267 bytes.  A binary comparison of the extracted file contents shows them identical. Unfortunately, the repaired version doesn't work.  When launched, you get 2 error dialogs: "The specified module could not be found. LoadLibrary (pythondll) failed", click OK and "C:\Program Files\Gourmet\PYTHON26.DLL".  Pthyon26.dll doesn't even exist so I'm assuming the EXE does something on the fly with the zip.

    4. Some interface/operation bugs:
    On the main screen, you cannot resize the column widths.
    When editing ingredients, if you press the delete key while in text edit mode (not the toolbar icon) it deletes the entire ingredient when it should only delete text.
    When editing ingredients, if you press the toolbar down (or up) icon, you lose focus after the first press and subsequent presses of the same icon have no effect.  You can do up-down to cycle between two ingredients but cannot press down-down to go down two lines.
    On the timer screen, numeric input doesn't work.  Don't know if this is inteded or not (I'm guessing it's not).
    On the unit converter, if density is a required item, it a> should be exapnded by default and b> should have a default value (I suggest water at 1.00).
    Word-wrapping seems to be inconsistent, e.g. on the main screen, the recipe "Bourbon And Honey Smoke-Roasted Pork Tenderloin" gets wrapped as "Bourbon And Honey Smoke-Roasted"\n"Pork Tenderloin"; also in the edit ingredients screen, " beef, cut into cubes for stewing" gets wrapped as  "beef, cut into cubes for"\n"stewing" but displays on a single line in the card view.

    5. After upgrading gtk back to 2.14.7 rev a, I tried Gourmet again.  Everything worked the same…

  • Richard Beels

    Richard Beels - 2010-03-01

    ahh, i spoke (typed) too soon, there is one difference in the new gtk.  It allows column widths to be adjusted.

  • greyson

    greyson - 2010-03-01

    Wow that was much more elaborate than what I had to say. =D

    1. I also found that the window resizing didn't get saved when opening new windows. I also noticed that if you minimized the main Gourmet window and brought it up while it was in full screen, then it would come up shrunk down again.

    2. I was having problems saving recipe files. I would select an image, hit save and it would just not react in anyway that was noticeable. I'd close the Edit Description page then it would ask if I wanted to save, I choose save. Then I would close the recipe file and it would ask me to save again, but when looking at the main Gourmet screen it seems that the image was not saved at all. I opened it back up and there was no image. So I closed it out completely, and launched Gourmet again and the image was there. But since doing that I've not had problems with saving while working in the description menu.

    3. It also seemed that Gourmet was not refreshing the changes I made unless I closed it out and opened it back up, but after closing and opening it a second time that problem no longer exists.

    So it seems that my problems resolved themselves after having restarted Gourmet the second and third time.

    XP SP3
    Gourmet version -  gourmet-0.15.4-alpha-full_gtkglade-2.12.9.exe

  • Richard Beels

    Richard Beels - 2010-03-01

    hi there.  :-)

    I was playing around with importing recipes and ran into the same problems you did with #2 & 3.  I was saying to myself: If I have to close and re-open every time I import something to see if it really imported, this is going to be a drag.  Then I noticed that I had spilled over to the second page of recipes.  :-O

    there still is some hinky behavior with showing newlt tped up or imported recipes after the process is done.  at least some type of dialog box saying success would be good.  as it is, you just get dumped to the main screen with no indication (no error message so that's a signal, i guess) but the recipe doesn't show.  I've closed and restarted more than a few times but it's still (not) happening…

  • Richard Beels

    Richard Beels - 2010-03-02

    some more errors….
    - you can resize the columns in the main window, but they don't stick between sessions.
    - something is weird with ingredient entry if you have the key editor plugin activated.  i was trying to enter a recipe using flour and it wouldn't save if I had flour as an ingredient.  I suppose flour itself isn't what's important but probably the variations of flour types overloaded some register/counter in the key editor or something?  When I turned off the plugin, I could save the recipe - the ingredients were identical to 30 seconds ago when I couldn't save the recipe.  I just ran into the problem again on a new recipe with "parsley" (the plugin is still deactivated and there's been a program restart in between as well) and it wouldn't save unless I misspelled parsley.
    - for the above problem, at first I thought it was related to the fractional importing: during a paste operation, the 3/4 wasn't recognized as a fraction and converted to the "3/4 character" and instead stayed as the string "3/4", manually entering "3/4 cup flour", the 3/4 string was converted to the character; entering ".75 cup flour" resulted in 3/4 (character).  Sometimes the fraction is converted to a single character, sometimes it's left as a string.  It should be consistent.

    - when doing ingredient importing, the parsing for TBS and tsp needs to be enhanced to correctly import "T", "T.", "t" and "t." as TBS and tsp. If the ingredient line is "1 T butter" it means "1" "TBS" "butter" not "1" <blank> "T butter".
    - there needs to be a way to edit the recipe from the main screen: both r-click menu and kbd shortcut preferred.
    - multiple column sorting can get messy real quick.  and what's the left-pointing triangle mean?  And the sort triangles can't be removed from ranking.  weird….

    all for now, time for bed….

  • tom

    tom - 2010-03-02

    beelsr - A lot of these behaviors sound different than what I'm used to on Linux, so I think many of these are windows-specific bugs. The normal thing on Linux is to run from the terminal and you usually get useful error output. I forget what the state of logging is on Windows and it sounds like the debug version is maybe broken right now, so that makes it a good bit harder to track down these bugs.

    One thought is that it's likely that some of these bugs are unicode related. Do the ingredients that are causing you trouble have any accented characters in them?

    The fraction behavior sounds quite puzzling to me. There are a variety of settings about whether your machine can handle unicode fractions (the single character ones) and so forth. Internally, Gourmet only stores numbers, so what's being displayed all goes through a single algorithm, so the display should pretty much always be consistent (in the recipe display view, that is). Gourmet isn't storing one thing for one ingredient and another for a different one (except in the one case you mentioned where the import parser failed and the fraction got included as part of the ingredient name).

    As to the enhancements, the T and t should be recognized (I'd thought this had already been addressed actually, but perhaps not).

    The main screen recipe editing is tricky - this was enabled in an early version and caused lots of usability problems (people would edit when they meant to open, etc.). However, the "batch edit" plugin allows you to edit any group of attributes for any group of selected recipes, so it actually should do what you want already.

    The sorting (arrows, etc) is all standard GTK sorting, so I'm hesitant to change it up since it would break consistency with the linux desktop. It might be worth considering whether it's better to disallow sorting by multiple columns… this would improve usability but inevitably beget a feature request from somewhere to put the multi-column sorting back.

    For any really important bugs or feature requests, please actually submit a bug or feature request (one per issue) which lets us keep track of them in an orderly manner. You last post, for example, should be 3 bug reports and 2 feature requests/enhancements.

  • Richard Beels

    Richard Beels - 2010-03-02

    1. Yeah, could be windows-specific.  I'm moving to a mac in a few months (hopefully) but since most of the world uses windows, a better windows version would help drive deployment of the app.  I'm intuitively sure these are windows-specific because, for example, I can't imagine having to resize every window every time would make it this far.  There's probably just some default setting that needs to be flipped for that.

    2. there are a couple non-standard characters.  the degree symbol and the word Châteaubriand.  None of the recipes with a degree nor the oh so awesome horseradish encrusted beef tenderloin recipe had a problem importing.  I now think the errors with the ingredients were the ingredient name (flour, parsley) and were related to the key editor functionality because once i mis-spelled the ingredients, the recipe could be saved no problem.

    3. the batch edit mode is indeed an awesome tool but it isn't exactly what i'm asking for.

    4. hmmm, the sorting doesn't seem to work the same as in wireshark but my mind is usually in a different mode when i'm wiresharking so maybe it's me.  ah, the engineer's conundrum…   :-

    I'll hit the 'bugzilla' tracker in a bit.  thanks for the reply.

  • Richard Beels

    Richard Beels - 2010-03-03

    i now know why some fractions weren't rendering properly.  they're not in the unicode table.  x/3, x/8 aren't in there.  doesn't seem mysterious now….   :-)

  • Jason Chard

    Jason Chard - 2010-04-12

    When adding a recepie to the shopping list clicking on Cancel still adds the recepie to the shopping list.

  • Anonymous

    Anonymous - 2010-05-04

    OK just tested on Windows 7(64bit) got the following errors:
    Traceback (most recent call last):
      File "Gourmet.pyw", line 2, in <module>
      File "zipextimporter.pyo", line 98, in load_module
    ImportError: MemoryLoadLibrary failed loading gtk\glade.pyd


Log in to post a comment.