GM crashing when trying to convert .eps

  • Anonymous - 2013-01-04


    When I try to convert an .eps file to .jpg GM crashes. If I use IM it work so I assume that GhostScript is working right.

    It's in danish, but the event log gives:
    Navn på program med fejl: gm.exe, version:, tidsstempel: 0x507ad385
    Navn på modul med fejl: MSVCR90.dll, version: 9.0.30729.6161, tidsstempel: 0x4dace5b9
    Undtagelseskode: 0xc0000417
    Forskydning med fejl 0x0002c993
    Proces-id 0x47b8
    Programmets starttidspunkt 0x01cdea8a4743294c
    Programsti: c:\program files (x86)\graphicsmagick-1.3.17-q16\gm.exe
    Modulsti: C:\Windows\WinSxS\x86_microsoft.vc90.crt_1fc8b3b9a1e18e3b_9.0.30729.6161_none_50934f2ebcb7eb57\MSVCR90.dll

  • Bob Friesenhahn

    Bob Friesenhahn - 2013-01-04

    Please make sure that the Ghostscript you have installed is a 32-bit application.  It is ok to have both 32 and 64-bit builds of Ghostscript installed at the same time.  If your ImageMagick is a 64-bit install and you have 64-bit Ghostscript then that would explain why ImageMagick is working.  There are development snapshot installers of GraphicsMagick (on the ftp site) which are 64-bit and will work with 64-bit Ghostscript.

    I have seen these crashes as well when the correct Ghostscript is not installed (or is wrong) and do plan to investigate.

  • Anonymous - 2013-01-07

    That makes sense.
    I can verify that I have the 64bit version of GS. I'll try to install the 32bit version.
    I tried to install the 64 bit GM and it gives the same result

  • Anonymous - 2013-01-07

    Yes that worked. Thank you!!

  • Bob Friesenhahn

    Bob Friesenhahn - 2013-01-07

    You are saying that the 64-bit GM crashes with the 64-bit Ghostscript?

    What Windows version are you using?  What Ghostscript version do you have installed?

  • Anonymous - 2013-01-08

    Yes, I'm on Windows 7 pro x64
    Now I have both gs906w64 and gs904w32 installed.

  • masterofd

    masterofd - 2013-08-29

    Hello there,

    we encounter the same problem with GM Version 1.3.17 and GhostScript 9.05 (both 32 bit Windows).

    Any clue how this could be solved?


  • Bob Friesenhahn

    Bob Friesenhahn - 2013-08-29

    The current GM release is 1.3.18. It is always good to use the most recent release.

    Details of the crash and information required to reproduce it (e.g. provide the EPS input file) are useful.

    Ghostscript is used to render the EPS to PPM format and it may be Ghostscript which is crashing before GraphicsMagick itself reads the image data. Under Windows, Ghostscript is loaded as a module and becomes part of the overall running program so it is not so clear about who is to blame.


Log in to post a comment.