Yes, you had a database corroption. Note that the database is not portable:

Note that you work with an old version, Mandriva 2.3.5-1 is actually 2.2.5, and we are now on 2.2.10, last week even 3.0.0 was released. I think you can find a 2.2.10 package for mandriva via cooker.


2008/4/1, Doug <>:
User Information:

I had examined some of the media attachments without carrying out any
editing or other changes, and then closed down.
During the closing down process an error message appeared - "ERROR",
etc. advising me to restart.

This error has occurred several times now. Thereafter the gramps db
could not be opened - it caused the message
"LOW LEVEL CORRUPTION of the Berkeley database" to appear; and I had to
restart from a backup, "saved as"
backup version, or earlier version.
Some of the earlier crashes occurred after editing, some after solely
viewing the database.

Error Details:

405107: ERROR: line 147: Unhandled exception
Traceback (most recent call last):
line 492, in quit
line 1077, in close
DBInvalidArgError: (22, 'Invalid argument -- txn_checkpoint: failed to
flush the buffer cache Invalid argument')

System Information:

Python version: 2.4.3 (#2, Sep 18 2006, 19:28:43) [GCC 4.1.1 20060724
(prerelease) (4.1.1-3mdk)]
BSDDB version:
Gramps version: 2.3.5-1
OS: Linux Mandriva 2007.0
Distribution: 2.6.17-5mdv

Check out the new Marketplace.
It's the best place to buy or sell services for
just about anything Open Source.;164216239;13503038;w?
Gramps-bugs mailing list