2008/1/30, Duncan Lithgow <dlithgow@gmail.com>:
Jim mentioned that in some cases "In fact, one may even be opening it
only to view the settings!"

I think there are several examples in gramps where a menu item is
named as an editor, but is in fact both an editor and a viewer. I
would be keen to change them to call them 'managers' or something. For
example, we have an 'Edit Bookmarks' entry. If you want to actually
*edit* the bookmarks then there should be an '...' because you must
give input before continuing. But if you're just using it to *look* at
your bookmarks then the '...' is unneeded. But if we called it 'Manage
Bookmarks' then as soon as it is open it has completed the task, hence
not requiring user input and not requiring '...'.

Does that sound like an idea? There are other similar entries in the
UI which might benefit from a similar approach. I think consistent
vocabulary is an important tool in simplifying the UI without actually
changing any functionality.

I think that is what Jim and I mean. Of course, the name must still cover what it does.