I think GRAMPS cannot connect to the database.

Is this the same PC/environment you made the grdb with? Please read: http://www.gramps-project.org/wiki/index.php?title=Recover_corrupted_grdb

The check tool is improved also in version 2.2.9, but this error is new to me.


2007/12/20, Dave Pawson <dave.pawson@gmail.com >:
User Information:

Tried, failed to open a .grdb file.
Seemed as if the app had an open file so tried to repair it.
This happened. dave.pawson@gmail.com

Error Details:

78037: ERROR: _Tool.py: line 271: Failed to start tool.
Traceback (most recent call last):
  File "/usr/share/gramps/PluginUtils/_Tool.py", line 267, in gui_tool
    tool_class(dbstate, uistate, options_class, name, callback)
  File "/usr/share/gramps/plugins/Check.py", line 161, in __init__
  File "/usr/share/gramps/plugins/Check.py", line 89, in low_level
    if _table_low_level(db,the_map[1]):
  File "/usr/share/gramps/plugins/Check.py", line 101, in _table_low_level
    handle_list = table.keys()
AttributeError: 'NoneType' object has no attribute 'keys'

System Information:

Python version: 2.5.1 (r251:54863, Oct 30 2007, 13:54:11) [GCC 4.1.2
20070925 (Red Hat 4.1.2-33)]
BSDDB version:
Gramps version: 2.2.8-0.SVN
OS: Linux

This SF.net email is sponsored by: Microsoft
Defy all challenges. Microsoft(R) Visual Studio 2005.
Gramps-bugs mailing list