On May 18, 2013, at 12:11 PM, Guilherme Brondani Torri <guitorri@gmail.com> wrote:

On 18/05/13 18:19, John Ralls wrote:
On May 18, 2013, at 7:46 AM, Guilherme Brondani Torri <guitorri@gmail.com> wrote:

1) berkeleydb still doesn't like the two commands in one line.
--> solved my building manually
What's the actual error here? What shell (bash, tcsh, ...) are you using?
I'm using a standard Terminal with bash, but jhbuild is running sh, no?
I don't get it. I just started the shell and copied the command as written below and it went ok.

~ $ jhbuild build berkeleydb --force
*** Checking out berkeleydb *** [1/1]
*** Configuring berkeleydb *** [1/1]
cd build_unix; ../dist/configure --prefix /Users/guilherme/gtk/inst --libdir '/Users/guilherme/gtk/inst/lib' 
/bin/sh: ../dist/configure: No such file or directory
*** Error during phase configure of berkeleydb: ########## Error running cd build_unix; ../dist/configure --prefix /Users/guilherme/gtk/inst --libdir '/Users/guilherme/gtk/inst/lib'   *** [1/1]

It turns out that jhbuild was ignoring the 'cd'. Adding a ';' in front so that cd was the
second command works, so I've made that change. Oddly, if the first command is something that
just prints and exits, the output shows up, so jhbuild must be doing something special. I'll
have to pull on that string a bit, but the issue here is dealt with: The change is pushed.

John Ralls