Greetings All:

For rpm- basd linux systems, I took a long time in order to getting osm-gps-map working for myself...

First of all, I need to make sure that you understand that these instructions are based on Fedora 15/ 16...

In osm-gps-map-0.7.3 directory, I had to do:
Normal user...

2) ./configure --disable-introspection --disable-static --enable-gtk-doc
3) make

Root user:
4) make install #C library

Normal user...
1) cd python
2) repeat configure command from above...
3) make

Root User:
4) make install #Python-bindings

I know that you seem to be a power user because you seem to know your way around a terminal and in building packages from source?  I outlined all steps that I had to go through to get it to work...

If you are also interested in re-building a source rpm, I am willing to share my source rpms that I have built for myself...?

I know that they are built on Fedora, but Mandriva RPMS will build on Fedora, so I am thinking that it will work the same for Mandriva...

Sincerely yours,
Rob G. Healey

On Tue, Jul 26, 2011 at 7:43 AM, Yiannis Kakavas <> wrote:
On 07/26/2011 04:37 PM, Gordonjcp wrote:
> On Tue, 19 Jul 2011 09:49:16 -0700 (PDT)
> doug <> wrote:
>> I'm trying to build python-osmgpsmap into the genealogy program Gramps
>> 3.3 on linux (Mandriva 2009.1) from tarball and having problems.
> Aren't there packages for osmgpsmap already, for Mandriva?
>> I've untarred osmgpsmap-0.7.3.tar.gz and python-
>> osmgpsmap-0.7.3.tar.gz, copied the folder python-osmgpsmap-0.7.3 into
>> the folder osmgpsmap-0.7.3, done a simple configure, make, make
> You shouldn't need to do that, but I can't see it making any difference.
>> install (as root) in osmgpsmap-0.7.3; then cd'd to python-
>> osmgpsmap-0.7.3 and done a simple configure, make, make install (as
>> root) there.
>> The libosmgpsmap libraries are installed in /usr/local/lib; the
>> osmgpsmap libraries in /usr/local/lib64/python2.6/site-packages/
>> gtk-2.0.
>> The commands 'python' , 'import osmgpsmap' , 'print
>> osmgpsmap.__file__' run in /usr/local/lib64/python2.6/site-packages/
>> gtk-2.0 and anywhere else I care to link to the osmgpsmap libraries,
>> so the module itself is OK.
>> But Gramps will *not* link in the osmgpsmap module however I run './
>> configure' , 'make', make install' in the untarr'ed gramps folder.
>> Having linked the osmgpsmap libararies into /usr/local/lib I've tried
>> LD_LIBRARY_PATH=/usr/local/lib;
>> .configure LIBS=-losmgpsmap..................................... etc.;
>> played around with PKG_CONFIG_PATH ............... till I'm blue in
>> the face. Gramps keeps telling me the osmgpsmap module has not been
>> found.
> Isn't Gramps written in Python?  Why would you be linking the C libraries there?  If you can import and use python-osmgpsmap (try the Python example from the osmgpsmap website) then it should work just fine in Gramps too.

I second that, if Gramps is written in python , then you shouldn't need
anything more than 'import osmgpsmap' in the gramps code. can you import
osmgpsmap running the python shell from elsewhere on your system ?

Sincerely yours,
Rob G. Healey

"Always surround yourself with people that inspire you to