My record is still there. There's hope!
Looking in plain text at my @I, I see an @F that I am still married to my wife and she does not appear in any other @F and we still have two CHIL's.
So the data appear to still be intact.

There are 362 Gramplets when I open the GED.
When I cat the ged file and grep INDI I get 443.
When I pipe that to sort & uniq I still get 443.

I tried a Tools -> Family Tree Repair -> Check & Repair database on a copy and it said "41 broken child-family links were fixed" and 4 corrupted family relationship fixed.
However the total number of people stayed the same.

Should I try to revert to a 2010 Gramps, open the GED and resave it in the Gramps format?
Or am I going to have to try and dummy up a PERL script to fix it?
Other thoughts welcome & thank you,

Date: Thu, 14 Feb 2013 15:28:50 +0100
Subject: Re: [Gramps-bugs] corruption

2013/2/13 Ben Clark <>
I last used Gramps 3 years ago (probably from Ubuntu 9.10) and got a great PDF after many dozens of hours inputting data.
I also exported the GEDCOM file and now, when I reopen the GED file on a new computer (Ubuntu 12.04) there are missing records and mashed relationships.
For example, my own record was AWOL and my wife was married to my great-great-great-grandfather.
Any thoughts on how this happened or what I might be able to do about it?

GEDCOM is not the native format of Gramps, and over time many fixes in import and export happened.
I can only assume 3 years ago there where certain bugs in the export. Eg, it could be that you had by accident the same ID for you and your grandfather, and only one was exported, making your wif married with you. We would need to test with a version of 2009 if that was a bug then.

Have a look in the Gedcom if you are really not in it. If not, nothing can be done, it is a bug of 2009 with export to GEDCOM.
Do you not have an export to the Gramps format, which ends with .gramps or .xml ?

Thanks in advance,