Thanks everyone but I have problems here.

I did go to the wiki for the eee user after unsuccessfully trying to figure out how to add "multiverse" to Synaptic, I just couldn't find where it was done.

I agree, Xandros is way to Windows-like and I don't like it as much as Ubuntu for sure. In Xandros, I can right click on the deb file but "install" is not an option as it is in Ubuntu.

So going to the Eee wiki, I found the command for what I thought was the installation for Gramps (or I should say update).

GRAMPS won't work at all now :( on this Xandros/Eee computer. Here is my error message:

/home/user> sudo dpkg -i gramps_3.0.0-6_all.deb

(Reading database ... 79578 files and directories currently installed.)

Preparing to replace gramps 2.2.10-2 (using gramps_3.0.0-6_all.deb) ...

INFO: using unsupported version '/usr/bin/python2.5'

Unpacking replacement gramps ...

dpkg: dependency problems prevent configuration of gramps:

gramps depends on python (>= 2.4.4-6); however:

Version of python on system is 2.4.4-2.

gramps depends on python-central (>= 0.6.2); however:

Version of python-central on system is 0.5.12.

dpkg: error processing gramps (--install):

dependency problems - leaving unconfigured

Errors were encountered while processing:

gramps



From the above error message I can see that obvi0usly python on my Eee is not the latest version...no idea how to change that. Same with "Python-central"...no idea what that is either.

I guess I should have left well enough alone but I know others using this setup are using Gramps 3.0 and it would indeed be so handy to have the same version on both computers.

So is there an easy way to undo my attempt at an install/undate and get GRamps 2.10 back? Or should I delete GRAMPS and start over?

I am nervous about changing files on my Eee because I've read horror stories regarding the updates.

Sorry for rambling, I hope someone can help.
Thank you,
Laura
> From: laidlaws@hotkey.net.au
> To: gramps-users@lists.sourceforge.net
> Date: Tue, 27 May 2008 00:29:04 +1000
> Subject: Re: [Gramps-users] how to update to GRAMPS 3.0 on Xandros
>
> Whatever package type Xandros uses, you should be able to download it. Tony
> talks about Synaptic, which is Debian and Ubuntu style. But my distro
> (Mandriva with RPM) hasn't made 3.0 available yet. You are luckier; there
> are .deb files on SourceForge.
>
> I looked at Xandros a while back. It was TOO like Windows. Even the standard
> Linux config files weren't where I was accustomed to look. But I didn't give
> it a thorough workout.
>
> Doug.
>
> On Monday 26 May 2008 11:52:26 pm Laura Mellen wrote:
> > > Hi,
> > >
> > > I'm a fellow eeePC user - great machine!
> > >
> > > I think you'll find you need to change your repository settings in
> > > Synaptic to "Multiverse" repos. That will bring in all repos, even those
> > > which have licensing issues etc. From there you'll be able to install
> > > Gramps new version.
> >
> > Yes, I do love my Eee!
> >
> > I will boot it up in a bit and see if repository settings are Multiverse,
> > thanks for the idea. It would be so nice to be able to install GRAMPS
> > update that easily.
> >
> > > As to the download for Xandros you've done, perhaps you would like to go
> > > here
> > >
> > > http://www.eeeuser.com/
> > >
> > > which is the eeePC site, with forums and a Wike about how to instal
> > > downloaded programs. HTH
> >
> > Yes, I'll be sure to check it out...
> > Thanks!
> > Laura
> >
Hello, I hope someone can help me.
> > >
> > > I have Gramps 3.0 installed on my desktop computer running Ubuntu 7.10.
> > >
> > > I also have GRAMPS running on my Asus Eee that uses Xandros. However,
> > > this version of GRAMPS is 2.10 (I think it's called). I would like to
> > > update my Eee so it too, is running 3.0. That way I can share files
> > > between computers like I was doing before when both operating systems
> > > were using 2.10. I feel 3.0 is so much better, I'd really like it on my
> > > little Eee.
> > >
> > > Here's where I get confused. According the the sourceforge site I was
> > > taken to, Synaptic is the best way to update. However my Synaptic package
> > > manager tells me I am unable to update to 3.0. If I go to Programs/force
> > > update, it still shows that I am using the latest version of GRAMPS,
> > > which of course, I'm not. I do have debian in the repository list.
> > >
> > > I also looked in the GRAMPS program itself to see if there was "update
> > > now" in the menu but couldn't find it.
> > >
> > > So at the Sourceforge site I downloaded and saved to desktop:
> > > gramps_3.0.0-6_all.deb. Now I have no clue what to do with it! I want to
> > > learn how to do more with the terminal, but at this point I am
> > > remembering nothing at all as to what step would be next.
> > >
> > > Maybe my 49 year old brain is incapable of learning new things because it
> > > seems I should have caught on how to do this by now... I welcome all and
> > > any help to get me through this.
> > >Laura



Give to a good cause with every e-mail. Join the iím Initiative from Microsoft.