Alain,

I do not see the relation with Gramps.
Gramps does not need compilation, it is written in a scripting language.

If you use Ubuntu, and you start to compile and install some of the core packages (glib, ...), then it is normal that you get problems if you are not a very experienced programmer / packager.

For easy Gramps in Ubuntu, do:
sudo apt-get install gramps
then obtain the source code from sourcefore of the latest version, and do:

./autogen.sh
make

Install dev packages autogen complains about as needed with the package manager.
Then the latest version can be run with the comman:

python src/gramps.py

Benny

2011/1/26 Alain AUPEIX <alain.aupeix@wanadoo.fr>
Hi, I want to install all the paquets and the source under ubuntu 10.10.

Using the list on the documentation page, I begin to install.

I first install this:

sudo apt-get install intltool
sudo apt-get install python2.6-dev
sudo apt-get install python-cairo-dev
sudo apt-get install libtiff4-dev
sudo apt-get install libxcomposite-dev

no problem, then this (configure + make + make install) :

libffi-3.0.9
pango-1.28.3
pygobject-2.21.3
atk-1.32.0
glib-2.26.0
pygtk-2.22.0
gdk-pixbuf-2.21.7
gtk+-2.22.1

The first time I tried it, was under Ubuntu 9.10, and I don't search
why, I install then 10.04 and don't try again.

I have tried under 10.10, a first time, and the problem was the same :
after a boot, Applications and System submenus were now in english, and
more ennoying, Computer and Network submenus of Shortcuts were also in
english, but didn't work anymore. Trash in 'Tableau de bord' was hidden.
As I didn't found the reason, I reinstall 10.10. After reinstall, I
found about half a dozen of trash ...

I begin a new try, but less stupidly ( I kept the installs folder), and
I test after these packets installed. The problems were already here,
but I was now able to uninstall packet one by one.

In fact the responsive was: glib-2.26.0. I tried a previous version
(2.25.17), but it was the same. As I have halready had these problems
with older version og glib, I think there is perhaps some parameters to
change to make it ok.

Does anybody had such problems ? and how did you solve it ?

I know it's not a gramps problem, but I really need it to use gramps.

Last question, there were some times, the version of django usable was
1.0, I have download 1.2.4, and 1.3beta. Will these version work with
gramps server ?

Thanks

A+



------------------------------------------------------------------------------
Special Offer-- Download ArcSight Logger for FREE (a $49 USD value)!
Finally, a world-class log management solution at an even better price-free!
Download using promo code Free_Logger_4_Dev2Dev. Offer expires
February 28th, so secure your free ArcSight Logger TODAY!
http://p.sf.net/sfu/arcsight-sfd2d
_______________________________________________
Gramps-devel mailing list
Gramps-devel@lists.sourceforge.net
https://lists.sourceforge.net/lists/listinfo/gramps-devel