Today I installed Gramps 4.0.3-1 from software.opensuse.org/packages/gramps.  I used the 1 Click Install for the official release of 4.0.4 under openSUSE Factory.  I am using openSUSE 13.1.  The first machine that I installed it on last night (6-12-14), everything went well and the software appears to function correctly.  On today's install (6-13-14), from the same source, I received the following error report.

Traceback (most recent call last):

File "/usr/lib/python2.7/site-packages/gramps/gui/viewmanager.py", line 964, in __create_pagepage_display = page.get_display()
File "/usr/lib/python2.7/site-packages/gramps/gui/views/pageview.py", line 400, in get_displayself.top = self.build_interface()
File "/usr/lib/python2.7/site-packages/gramps/gui/views/pageview.py", line 153, in build_interface
defaults[0])
File "/usr/lib/python2.7/site-packages/gramps/gui/widgets/grampletbar.py", line 138, in __init__
self.dbstate, self.uistate)
File "/usr/lib/python2.7/site-packages/gramps/gui/widgets/grampletpane.py", line 184, in make_requested_gramplet
getattr(module, opts["content"])(gui)
File "/usr/lib/python2.7/site-packages/gramps/gen/plug/_gramplet.py", line 64, in __init__
self.init()
File "/usr/lib/python2.7/site-packages/gramps/plugins/gramplet/filter.py", line 49, in init
self.__filter_clicked)
File "/usr/lib/python2.7/site-packages/gramps/gui/filters/sidebar/_familysidebarfilter.py", line 95, in __init__
SidebarFilter.__init__(self, dbstate, uistate, "Family")
File "/usr/lib/python2.7/site-packages/gramps/gui/filters/sidebar/_sidebarfilter.py", line 62, in __init__
self._init_interface()
File "/usr/lib/python2.7/site-packages/gramps/gui/filters/sidebar/_sidebarfilter.py", line 91, in _init_interface
hbox.set_layout(Gtk.ButtonBoxStyle.START)
File "/usr/lib/python2.7/site-packages/gi/module.py", line 313, in __getattr__
return getattr(self._introspection_module, name)
File "/usr/lib/python2.7/site-packages/gi/module.py", line 165, in __getattr__
setattr(wrapper, value_name, wrapper(value_info.get_value()))
ValueError: invalid enum value: 6

This was received when attempted to use the Families section of the software.  Earlier, I received a similar report when attempting to use the People section of the software.  Would it be possible for you to tell me what the report means and how I can fix it? 

On the first machine,  from somewhere I got this message:
    Geography functionality will not be available.  To build it for Gramps see gramps-project.org/wiki                 /index.php?title=GEPS_029:_GTC3-GObject_introspection_Conversion#OsmGpsMap_for_Geography.

I followed the directions listed under OsmGpsMap for Geography taking the following steps:

Installed the following packages in Yast:
    libsoup-2.4
    libsoup2.4-dev
    gtk+-3.0
    gtk+-3.0-dev
    cairo
    gobject-introspection
    gobject-instrospection-dev
    gnome-autogen.sh
    checkinstall

Downloaded the 1.0.1 source tar from nzjrs.github.io/osm-gps-map/
Moved the file to /opt
su
tar zxvf osm-gps-map-1.0.1.tar.gz
cd osm-gps-map--1.0.1
gnome-autogen.sh
make
make install
cp /usr/local/lib/girepository-1.0/osm-gps-map-1.0.1.typelib  /usr/lib/girepository-1.0/
gnome-qutogen.sh prefix+/usr
make
checkinstall make install

I now have no idea if all of this worked.  How do I access this new functionality?
I did not do this on the second machine.  Could this be the reason that it is not working properly?

Any help, hints or new directions to go in to make this work would be greatly appreciated.

Julie