I have just managed to upgrade my GrampsAIO installation on Windows Vista to run gramps 3.4.

Here's what I did - it seemed to work, and I can still run my old GrampsAOI version 3.3 (though obviously not on any upgraded trees), but I am not an expert, and I don't know if this will work for anyone else. There may be a risk of breaking your current GrampsAOI installation.
  1. Back up all your gramps trees to XML.
  2. download gramps-3.4.0.tar.gz from sourceforge
  3. decompress file and extract gramps source (I used 7-Zip)
  4. make a copy of c:\Program Files\GrampsAIO, and its subdirectories. I called mine c:\Program Files\GrampsAIO-3.4
  5. delete contents of c:\Program Files\GrampsAIO-3.4\gramps
  6. copy contents of gramps3.4.0\src directory from download to c:\Program Files\GrampsAIO-3.4\gramps
  7. copy GrampsAIO shortcut file and edit the copy to use the new directory GrampsAIO-3.4

Think hard, and make backups before you attempt this.

Mary


On 29/05/2012 07:39, Terry Corbet wrote:
I know that someday I am going to have to finally get off of Windows XP, but I did not realize that the pendulum had swung so far away.  Is there really a larger group of people running 64-bit enabled versions of Windows?  I guess it is at least so for those of you upon whom we depend to get us an installable version of the latest code.  Is there an expected date for 3.4 All-in-One for us old slackers running 32-bit Windows XP?  Thank you.