Alex Roitman wrote:

On 07/15/2005 08:04:43 PM, Bill Pier wrote:
I've recently upgraded from Gramps 1.0.8 to 2.0.5
using an rpm, though I tried building it too with the same results:

seg fault at startup - no other error messages

 GRAMPS     : 2.0.5-1mdk
 Python     : 2.4-5mdk
 GTK+-2.0   : 2.6.4
 PyGTK      : 2.6.2
 O/S        : Mandrake 10.1

Everything looks sane. People run gramps under these conditions
without problems. 

Any suggestions on how to debug this problem?

The ideal scenario would be to rebuild all the underlying code (python,
gtk and gnome libs, and pygtk) with the debugging symbols enabled and
then run gramps under gdb:
   $ cd /usr/share/gramps
   $ gdb python
   (gdb) run gramps

This is most likely too much to ask, we all understand that :-)

I've tried  backing down releases but to no avail - no change.
Clearly to me, some lib called in bowels of python is
a problem, but I don't know how to trace this.

Either python or gtk/gnome or pygtk/gnome-python.
Try running it under gdb, maybe something will give a hint
even without debugging symbols?

You could also ask Mandrake people -- whatever the code in gramps
does, it should not be able to segfault python. Since it does,
something is not right with the underlying libs. This could potentially
be a source of a security problem, so they have a free testcase in form
of gramps :-) They should be capable of at least locating the culprit
statement in gramps, since they compile and package all the libs.
While they're at it, they will give us insights of what may be wrong.

If you get any relevant feedback from Mandrake developers, please
share it with us! If there's some bug tracking system and you file
a report in it, please let us know the URL so that we can stay posted.


OK, I've checked and rechecked my python upgrade/install to
make sure that at least the rpm's are copacetic (I know, I know,
RPM package management sucks and isn't the best ...).
Running python with -v produces some messages ending with:
# /usr/lib/python2.4/xml/parsers/expat.pyc matches /usr/lib/python2.4/xml/parsers/
import xml.parsers.expat # precompiled from /usr/lib/python2.4/xml/parsers/expat.pyc
dlopen("/usr/lib/python2.4/lib-dynload/", 2);
zsh: segmentation fault  python -v $GRAMPSDIR/

Any ideas?
The lib file looks fine and is/was provided by the python-2.4 rpm.


P.S., SHOOT! DANG!, (etc.); upon further checking it seems that
used to be provided by PyXML (rpm) which is python 2.3 specific; so is
gramps not compat. with python 2.4 as built/structured by MDK?