I have a Windows Vista 32-bit computer with an added Corsair Force 3 SSD that came factory partitioned GPT, the microprocessor is a 64-bit Intel Core 2 E6300.  I am working on my first computer build and will transfer this SSD to it as the C: System drive by loading an OS on it in the new computer.  I want to end up dual booting with Linux and Windows.  I will wait for Windows 8 later this year.  In the meantime I will use Linux to set up btrfs partitions to store my data safely from corruption/"bit rot".  I have not used Linux before and am slowly learning.  I have decided to use the Linux kernal efi stub to boot with, which currently limits me to Ubunto Quantal Quetzal ISOs.  In my research I have found that GPT fdisk should safely allow me to setup the partitions for GPT boot (ESP = EFI System Partition) and MSR (MicroSoft Reserved partition) ahead of time so neither install of Linux or Windows will corrupt or disturb the other partitions.  I have tried to create both the ESP and a regular Windows basic partition in the correct spot using gdisk versions from 0.7.1 through 0.8.4 with the same result.  I can setup either partition and verify it with "v" with no errors, but when subsequently doing "w" to write the partition to unallocated space (per Microsoft Management Console's Disk Management and gdisk) I get the following warning and no created partition.
 
OK; writing new GUID partition table (GPT) to \\.\physicaldrive2.
Warning! An error was reported when writing the partition table! This error
MIGHT be harmless, but you may have trashed the disk!
 
Command ( ? for help):
 
This same error also happens when trying to delete a partition created in gdisk or one I created in Windows as a filler and disposable partition.  No partitions are ever created or deleted.
From what I know gdisk should be able to create a generic data partition on this non-boot/data SSD.  The SSD has a protective MBR, and is partitioned as GPT per both gdisk and Windows.  Are there any diagnostic tests I can run to determine where the write of the new GPT partition is failing?
 
Alan