SourceForge has been redesigned. Learn more.

Samsung B2710 WORKING

  • Horst Stocker

    Horst Stocker - 2012-01-09

    I got GPSMID to work on the SAMSUNG B2710.

    - use a small GPSMID midlet (larger maps can be loaded from another gpsmid-jar file sitting on the memory card)
    - the internal GPS (JSR 179) seems to be blocked but i managed to unlock it. I had to removed some files from the internal memory.   For detailed instructions see :
    Perhaps this is just an issue with signing and or security settings.
    - Tracking works fine

    • karystxr

      karystxr - 2015-01-09

      Hey buddy I tried to do the same but when i try to open the .jar file inside the mobile it says invalid file.
      Can you guess why? I think normally it should open .jar files,shouldn't it?
      I tried another .jar file,the same.

  • Jozef Riha

    Jozef Riha - 2012-01-11

    can you run gpsmid (does it record) in background?

  • Horst Stocker

    Horst Stocker - 2012-01-12

    It can be minimized. But need to check wether track recording is continued when minimized.
    As it reconnects to the internal gps when continued from minimzed mode i am afraid (but not sure) the internal gps is stopped and track recording is not available during background mode.

  • Jozef Riha

    Jozef Riha - 2012-01-13

    in the meantime i succeeded in converting gpsmid from j2me format to alx/cod in an attempt to make it appear as a native application. installed application however throws an error and terminates when executing: verification error 3146 at offset 2b37 (codfile verson 79) :-(

  • Bonum

    Bonum - 2012-05-05

    I got this phone a few days ago. I downloaded the signed jar/jad files, the jad file (with the signature?) wasn't recognized but I could install from the jar anyway. Unzipped the map to the memory card (60 kbps over bluetooth, 160 kbps over usb -I have to get a card reader!), and it is working pretty good.

    I did not need to do any hacks to get the internal gps working. Although running the built in gps program (hidden in settings - phone - gps) before starting gives more feedback when acquiring satellites.

    I still have to press yes to two questions every time I start the program, it doesn't seem to remember the settings. But all in all, so far it's working great.

  • Jyrki Kuoppala

    Jyrki Kuoppala - 2012-05-05

    Intersting that you at least got the USB data card connection working - I used a different phone as a card reader, as it seem the phone never came access to the memory card. Well, I'm using Linux, and it did recognize a block device connected, but for some reason it never did mount the memory card in the phone, also manual mounting failed. Also appeared that the phone was quite slow to give access to the memory card even when just using the card from the phone - possibly one of the phones which has for whatever reason been programmed to go though all directories on the memory card when starting.

  • Bonum

    Bonum - 2012-05-06

    Well, working… I won't try the usb connection again if I can find another way. The connector on the phone seems a bit too deep, I had to push the cable in very hard to get it working and I'm afraid of damaging the socket which is needed for charging.

    After unmounting in windows, the phone stalled for a long time. My first attempt with a brand new 8 Gb card, I gave up waiting and removed the battery. That card is now unusable, I'll have to find some other device to reformat it or something. I had an older 2 Gb card that I tried. Phone stalled for a few minutes after the transfer, the memory card icon was blinking and I thought I had ruined another card. But after a long wait and a soft reboot, the phone's been working.

    I'm using the Swedish map which is about 130 Mb I think. Maybe a smaller map would be better.

  • Gerald Klatt

    Gerald Klatt - 2012-08-19

    I didn`t found something about handling a problem with my Samsung B2710, so I want to tell here my solution for other users.
    As it is known, it´s not possible to change number fields by keys of B2710 in the setup of gpsmid. So I export the setup into a cfg-file (defaultname is GPSMID.cfg). First I thought I can edit this file with notepad or something else. But it`s not an ASCII-File. After this I used the Microemulator, started gpsmid and loaded a prepared GPSMID.cfg. With PC it was easy to edit the numeric fields and after that export again in GPSMid.cfg. At last, this configuation-File can load into the phone and everything went good.

    If someone knows an easier way, I`m curious….

  • Jyrki Kuoppala

    Jyrki Kuoppala - 2012-08-19

    What field(s) do you have problems with? I think I fixed this for at least some fields a while ago.

    Can't find it on WHATSNEW though, only this:

        - make photos work on Samsung Xcover B271 (and probably some other Samsungs too)

  • RanX

    RanX - 2012-09-04

    Hello everybody,

    after some fiddling around with v. 0.80 I found a bug report, that said this version wont work on the B2710.
    After switching back to 0.77 the installation and start went fawless.
    Access to internal GPS works out of the box with no other steps needed.

    Then it turned out that runnig GPSmid with larger maps is slightly impossible.
    I downloaded my region's map (Germany; state Lower Saxony)
    and pointed the map directory to the .jar (120 MB) on my cf memory card.

    After 'bout a minute of silence GPSmid bails out without success.
    I also tried to unzip and pointed settings to the folder having all the unzipped files inside.
    Still no luck.

    I'm sorry to say - as I appreciate the work done on that project
    but it doesn't make much sense to run the app whithout maps loaded that cover a reasonable area.

    So I'd be happy to hear if there's a way to load maps of the named size.

    Best Regards


  • Hector

    Hector - 2012-11-20

    Hi everybody!

    So I got the GT-B2710 a few days ago and tried to get a working GPS software for this phone.
    Creating a midlet of my neighbourhood from the germany.osm.pbf worked fine, installation also worked without any problems. (At the Moment only on the internal memory, as I will only get a memory card at the end of the week… is it possible to install GpsMid onto the memory card, or do I have to put it in a separate folder there?)
    The first one didn't seem to get any signal, so I created several midlets with different options.

    One midlet then connected to the JSR-179 pretty well, and showed my position really precisely. However, the piece of the map turned out to be a bit too small, so I created a slightly bigger one. This one - and every one I created afterwards until now - produced an error message that the JSR-179 is not available in this version (original text in German: "Positions-API (JSR-179) ist in dieser Version von GpsMid nicht vorhanden").
    However, I created both the working midlet and the other ones with the same version Osm2GpsMid-0.7.7-map69.jar, so I doubt that it's the fault of the program version -since it worked perfectly fine once-, but rather of a wrong setting concerning the map creation.

    My problem is: I overwrote the working file without noting which options I used for its creation. Not a smart move, I have to admit… Can anyone help me out with a configuration that's maybe known for working with the B2710?
    Could the setting "Phone capabilities template" have that impact on the fact if the program is able to connect to the GPS?

    I would really appreciate any help in English or German, maybe even in a way that a total newbie to file modding like myself is able to understand. ;)

  • Jyrki Kuoppala

    Jyrki Kuoppala - 2012-11-20

    "Could the setting "Phone capabilities template" have that impact on the fact if the program is able to connect to the GPS?"

    Yes, that's probably it.  If you don't need online access, GpsMid-Generic-full is a reasonable choice, if you want online, GpsMid-Generic-full-connected

  • Adam Pribyl

    Adam Pribyl - 2013-01-04

    To disable the two questiond on every GPSMid start use TkFileExplorer and delete
    Phone( P: )/AppEx/User/Java/Games/GPSMid/MANIFEST.MF
    Phone( P: )/AppEx/User/Java/Games/GPSMid/appdb/settings.bin

    I used 191MB GpsMidBay Bayern map from with 0.7.7 version without a problem, just loading the map takes some time. If you have memory problems, consider freeing some internal memory. Also you may try to change the memory limit under

    GPSMid is quick to lock the GPS, there is no need to start GPS from the menu.

    However I did not found a way how to search for a street to navigate to under Menu/Search. After "Search for name (name)" on the screen I can only enter numbers. How do I enter a letters, or do the numbers have some special meaning (like T9)?

  • Hector

    Hector - 2013-01-10

    So during the last few weeks, I've created a few quite small midlets for geocaching in certain areas (all around 1MB in size), and they all seem to work pretty well by now.

    But I have another question: I downloaded the complete pre-built Stuttgart-Midlet, which is about 36 MB in Size. I put the .jar on my Memory Card, but whenever I try to install it, it takes about 5 seconds until an error message appears which tells me, that the memory is full. The memory card I bought recently has a capacity of 16GB, so that shouldn't be thecause of the problem.

    I suppose that the phone tries to install the Midlet into the internal memory, and fails because of the 32 MB internal memory size… How can I tell the phone to install the midlet directly onto the memory card?

    @Covexx: I didn't use the search feature yet, but I had a similar problem when typing in coordinates for waypoints. All I got, was letters instead of numbers. And deleting them was not possible because the phone has no "C"-Button. But when you are at the textfield where you can enter your search, try holding the #-key for a few seconds. This should open the edit mode, where you can skip between numbers and letters, using the #-key again.

  • Adam Pribyl

    Adam Pribyl - 2013-01-10

    I know about the #hold trick, without this, the phone can not use many java apps, however, in the search this does not work.

    I tried now to load the Stuttgart map from the and I can load it without a problem - this is gpsmid 0.7.7, phone memory info shows 29MB internal memory available. In my opinion the gpsmid is not unpacking the whole .jar map.


Log in to post a comment.