I can't reply to a bug I've raised (FAO Roy Rankin)

Help
Dan Hatch
2013-05-03
2013-07-25
  • Dan Hatch

    Dan Hatch - 2013-05-03

    It seems silly I know, but I just can't see how to respond on a bug I've raised! Where am I meant to reply? I was expecting a reply textbox at the end or something?

    Anyway, this is the bug:
    149 USART problems with pic16f690

    ...and in reply to your comment Roy ( https://sourceforge.net/p/gpsim/bugs/149/#3b52 ), I have gotten the latest from SVN and the problem is still present. The simulation appears to run fine, but I just don't see any output in the usart window. I've tried the code on a real chip and it transmits just fine too. Is there any more information I could provide to help diagnose the problem?

     
  • Roy Rankin

    Roy Rankin - 2013-06-30

    Dan,

    I did not see this sooner.

    Were you logged in to sourceForge when you went to the bug? When I am logged in there is a box at the bottom of the bug for new comments.

    If it is a help my test program can be found in the SVN under regression/p16f690/eusart.asm. The first thing to check is for a baud rate issue.

    If you attach the .cod or .hex file and .stc if you are using one to the bug, It might help me work out the issue. Let me know if you have issues doing that.

    Roy

     
  • Dan Hatch

    Dan Hatch - 2013-07-25

    Yep, I'm logged in but I can't see the reply box :( No matter, as the issue is a non-issue. As you'd suggested the problem is indeed related to baud rate. I'd assumed that the simulator was running with a 4Mhz clock. It wasn't. As soon as I'd set the frequency correctly, it worked just perfectly. Sorry to have wasted your time on this!

     

Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:





No, thanks