Compiling gpsim

Help
2003-04-27
2003-06-19
  • Joël Kockerols

    Joël Kockerols - 2003-04-27

    Such as other (but in Thread 'welcome to help), I've some problem with compiling gpsim from scratch.

    OS :
    Linux Suse 8.1 Pro.

    Gcc :
    Reading specs from /usr/lib/gcc-lib/i486-suse-linux/3.2/specs
    Configured with: ../configure --enable-threads=posix --prefix=/usr --with-local-prefix=/usr/local --infodir=/usr/share/info --mandir=/usr/share/man --libdir=/usr/lib --enable-languages=c,c++,f77,objc,java,ada --enable-libgcj --with-gxx-include-dir=/usr/include/g++ --with-slibdir=/lib --with-system-zlib --enable-shared --enable-__cxa_atexit i486-suse-linux
    Thread model: posix
    gcc version 3.2

    glib : 1.2.10

    gtk+ : 1.2.10 (downloading + successfully compiled & installed)

    gtx+extra : 0.99.17 (downloading + successfully compiled & installed)

    gpsim : download + ./configure = OK. 
    Last lines & the make :

    gpsim-0.20.14 is now configured for

      Source directory:     .
      Installation prefix:  /usr/local
      C compiler:           gcc   -g -O2
      C++ compiler:         c++   -g -O2

      gui:                  yes

    /home/gpsim-0.20.14 # make
    make  all-recursive
    make[1]: Entre dans le rpertoire `/home/gpsim-0.20.14'
    Making all in cli
    make[2]: Entre dans le rpertoire `/home/gpsim-0.20.14/cli'
    /bin/sh ../libtool --mode=compile c++ -DHAVE_CONFIG_H -I. -I. -I.. -I/usr/local/include/gtk-1.2 -I/usr/include/glib-1.2 -I/usr/lib/glib/include -I/usr/X11R6/include     -g -O2 -c parse.cc
    c++ -DHAVE_CONFIG_H -I. -I. -I.. -I/usr/local/include/gtk-1.2 -I/usr/include/glib-1.2 -I/usr/lib/glib/include -I/usr/X11R6/include -g -O2 -c parse.cc -o parse.o
    In file included from /usr/include/g++/backward/iostream.h:31,
                     from parse.yy:24:
    /usr/include/g++/backward/backward_warning.h:32:2: warning: #warning This file includes at least one deprecated or antiquated header. Please consider using one of the 32 headers found in section 17.4.1.2 of the C++ standard. Examples include substituting the <X> header for the <X.h> header for C++ includes, or <sstream> instead of the deprecated header <strstream.h>. To disable this warning use -Wno-deprecated.
    In file included from parse.yy:32:
    command.h:55: 'string' is used as a type, but is not defined as a type.
    command.h:56: 'string' is used as a type, but is not defined as a type.
    command.h:82: parse error before `&' token
    make[2]: *** [parse.lo] Erreur 1
    make[2]: Quitte le rpertoire `/home/gpsim-0.20.14/cli'
    make[1]: *** [all-recursive] Erreur 1
    make[1]: Quitte le rpertoire `/home/gpsim-0.20.14'
    make: *** [all-recursive-am] Erreur 2

    This is the same problem as explained by sourceforg  in thread welcome to help.

    thx

    jo

     
    • Anonymous - 2003-05-24

      I get the same error. I guess this is because I use GCC 3.2 (Slackware 9.0) with the different c++-api (at
      least this is what I've heard), but I don't have any clue on how to fix it..

       
    • Anonymous - 2003-05-25

      Hi!
      I've encountered the same error (among others I'm tryng to solve)
      and bypassed it by adding the following line, on a Mandrake Linux 9:
      Line # 30 
      using namespace std;
      right after the first include declarations.
      Hope you have success!
      Paco.

       
    • Ralf Forsberg

      Ralf Forsberg - 2003-06-19
       

Log in to post a comment.