On Mon Apr 21 2014 at 6:57:07 PM, SRE <steve-babel@climber.org> wrote:
How about I sweeten the pot? I'll send $50 to anyone who can guide me thru
the process to doing a Windows build. Once that's done, I'll also

For the record, I'm leaving that $50 on the table just so an actual Windows Person takes a fresh look at it.  I'll gladly update whatever doc or scripts we need to, but let's get fresh perspective.

I use Cygwin so I can get to Subversion (I see now that Creator supports subversion natively...) but I just used the IDE and it all Just Worked.  ISTR there was some pain setting up the USB dev kit from Microsoft.

It seems that you're way off the beaten trail, wandering around in things I've never even heard of.  We do have some work we need to do in the *.pro - we need to move config.h out of HEADERS and put HAVE_CONFIG_H into DEFINES and HEADERS += config.h into that macx|linux box at the bottom and hoist whatever HAVE_FOO junk would have normally been set by configure in config.h into the win32 block.  I just spun a Windows build with a completely empty config.h and it worked.

Let's focus on getting you up in Creator instead of building your own development environment.
 
Something to do with identity-mounted environments, and a really broken MinGW:
http://sourceforge.net/p/mingw/mailman/mingw-dvlpr/thread/52B9F8F6.3070103%40gmail.com/#msg31783387

Sourceforget is dead right now, but I don't even know what that means.


 
>GPSBabel doesn't require old Qt; my primary development (on Mac) is 5.2.1.

Please see Adam's post about configure. I had the exact same result.

Adam's suffering is because he's on an 8 year old development environment.  His situation is different than yours.