Playing an rtsp url using mp4client

Authoring
joann
2007-08-31
2013-06-05
  • joann

    joann - 2007-08-31

    Hi,
      When I use mp4client to run an rtsp url by giving the following command:
    Mp4client rtsp://192.168.0.9/test.mp4
    I cant view it although the message is shown as "Service Connectedg...".There are no warnings too.

    This same file plays fine when I run it locally using the command :
    Mp4client test.mp4

    This mp4 file consist of 5 jpeg images(of 100KB size each )as five different slides.I encoded this file by giving the following command:
    MP4Box -def -mp4 test.bt -hint

    I am using Darwin Streaming Server to stream this file.Can anybody please help me out with this?

    Thanks,
    Joann

     
    • Richard Sotke

      Richard Sotke - 2007-08-31

      You can hint you MP4 file with "-ocr", but then all tracks with the jpegs will be streamed from the beginning - 5x100KB.

      It should also work, if you create from every jpeg an MP4 file and inline this MP4 files via rtsp.
      Here are two sample:
      http://gpac.sourceforge.net/test_suite/bifs-linking-inline-rtsp.html
      http://gpac.sourceforge.net/test_suite/bifs-linking-inline-rtsp-no-od.html

      (Seems the rtsp URL used in the sample isn't reachable).    

      If there are still problems, how does your BIFS text look?

      Regards
      Richard 

       
    • joann

      joann - 2007-09-01

      Thank you for the quick response.

      I tried out hinting the file with the -ocr option but still am not able to view the content.
      Your suggestion of keeping each image as separate mp4 files too didnt work.Although i would prefer having just one file rather than too many mp4 files.
      I am stuck here.Could u give me other suggestions?

      Thanks,
      Joann

       
      • Richard Sotke

        Richard Sotke - 2007-09-01

        I don't know what is going wrong. Maybe someone can help you, if you past the log from MP4Client at http://pastebin.com/ , and provide a link to it.

        "MP4Client -log-level debug -log-tools all -log-file log.txt rtsp://192.168.0.9/test.mp4"

        It could also help to know your test.bt.

         
    • Richard Sotke

      Richard Sotke - 2007-09-01

      I did a short test too. I hinted (-hint -ocr -iod) the sample from here http://gpac.sourceforge.net/test_suite/bifs-bitmap-image-resizing.html and tried to stream it with DSS 5.5.4, I had no luck. It happend the same you described. I can play the file locall but not via rtsp.  

       
    • joann

      joann - 2007-09-04

      I tried putting each image file as different rtsp urls.that seems to work with smaller number of files.But as the number of files increases,it gives me inconcictent results.

      Hope somebody is able to look into this problem.

       

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:





No, thanks