#16 More work on PNG driver

closed-out-of-date
None
5
2001-12-14
2001-09-28
No

Continued polishing of PNG driver previously submitted
as patch 430904. Now it handles filled boxes, and is a
little more paranoid about freeing resources from the
gd library.

requires:
libgd version 1.8.4 or 2.0.1

Ethan A Merritt
28 Sep 2001

Discussion

  • Ethan Merritt

    Ethan Merritt - 2001-09-28

    PNG driver (png.trm)

     
  • Levente Novák

    Levente Novák - 2001-10-01

    Logged In: YES
    user_id=337709

    It would be nice if the new png.trm could be compiled simply by overwriting the old one, then compiling the
    usual way (./configure). Else, please provide a short explanation on how you compile gnuplot with the new
    driver (what should be changed by hand, do we need to set HAVE_GD or something similar in config.h,
    etc...). Until now, I had always to fiddle with it to find the tricks needed to compile.
    Otherways it is a neat improvement over the old PNG driver. Keep the good work!

    Levente

     
  • Hans-Bernhard Broeker

    Logged In: YES
    user_id=27517

    Does this mean the other patch can now be removed, as
    obsolete?

     
  • Hans-Bernhard Broeker

    Logged In: YES
    user_id=27517

    As Ethan has opened yet another new patch entry for the next
    version of this, this one is now obsolete, I think. I'm
    putting this on
    "pending" status, meaning it'll automatically close in a
    while.

     
  • Hans-Bernhard Broeker

    • assigned_to: nobody --> broeker
    • status: open --> closed-out-of-date
     

Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:

JavaScript is required for this form.





No, thanks