decimalsign and postscript

  • luksus

    luksus - 2006-11-20

    I've got the problem that I want to use the decimalseperator "," for my input files. Using 'set decimalsign locale' works well for the x11 terminal but produces problems with postscript output because "," is interpreted wrongly in the postscript code.
    I also tried 'set decimalsign locale; set decimalsign "."' as suggested in the documetation. But this doesn't work properly. Only part of the postscript code appears with "." now, in other parts "," still ocurs. Is there a workarround or some kind of trick to avoid this or do I just have to pre-process my data resp. post-preocess the postscript?

    I'm using gnuplot vers. 4.2 rc1 on Linux SUSE 9.2


    • Hans-Bernhard Broeker

      > produces problems with postscript output because "," is interpreted wrongly

      Could you be more specific?  Complete actual input, and the actual error message would be helful.

      • luksus

        luksus - 2006-11-20

        my datafile is just something like:
        1,2 5,6
        1,3 5,7

        plotting it (plot "data.csv") gives no error message (neither with x11 nor with postscript)
        If I want to open the *.ps file with a extern programm, KGhostview in my case, it just shows me a blank page.
        so I made another plot after changing the "," in my datafile to "." and unsetting decimalsign.
        now the postscript looks as expected. I opend the postscript file with an ordinary texteditor and compared the code and doscovered that in the first case "," and in the second case "." is used in the code (witch seems perfeclty logical as I told gnuplot with 'set decimalsign locale' to do so)
        After I changed all the "," in the postscript-code to "." it worked fine. So I decided that "," in postscript-code is interpreted wrongly so KGhostview just shows me a blank page.
        Hope that makes the problem clearer.


Log in to post a comment.