SourceForge has been redesigned. Learn more.
Close

No TTF font support, using default

Help
paultan
2006-09-28
2013-02-10
  • paultan

    paultan - 2006-09-28

    Hi All,

    I have justed compiled the cvs version of Gnuplot (ver 4.1, p0). However, I have problem with the font and enhanced text.

    $ gnuplot myplot.gnu
    No TTF font support, using default
    set terminal png medium font arial 18 enhanced
                                      ^
    "myplot.gnu", line 1: invalid color spec, must be xRRGGBB

    Please help.

    $ gdlib-config --all
    GD library  2.0.33
    includedir: /usr/local/include
    cflags:     -I/usr/local/include
    ldflags:     -L/usr/local/lib -L/usr/local/lib  -L/usr/lib  -L/usr/X11R6/lib
    libs:       -lXpm -lX11 -ljpeg -lfontconfig -lfreetype -lpng12 -lz  -liconv
    libdir:     /usr/local/lib
    features:   GD_XPM GD_JPEG GD_FONTCONFIG GD_FREETYPE GD_PNG GD_GIF

    My gnuplot script is as follows:

    set terminal png medium font arial 18 enhanced
    set output 'output.png'
    set xlabel 'Enhanced Text( m{^2} )'
    set key box
    set key bottom left spacing 1.2
    set title 'My Title'
    set ylabel 'Y-Axis'
    plot 'mydata.dat' using 1:20 t 'data 1' with linespoint lw 3

     
    • Hans-Bernhard Broeker

      The most probable reason for this is that GD's or freetype's enhvironment variables for finding those fonts aren't present.

      You'll also have to check your gnuplot build's config.log or 'show version long' to find whether it connected to gd as expected.

       
    • paultan

      paultan - 2006-09-29

      Hi,

      I have this:

      gnuplot> show version long

              G N U P L O T
              Version 4.1 patchlevel 0
              last modified September 2006
              System: CYGWIN_NT-5.1 1.5.21(0.156/4/2)

              Copyright (C) 1986 - 1993, 1998, 2004
              Thomas Williams, Colin Kelley and many others

              Type `help` to access the on-line reference manual.
              The gnuplot FAQ is available from
                      http://www.gnuplot.info/faq/

              Send comments and help requests to  <gnuplot-beta@lists.sourceforge.net>
              Send bug reports and suggestions to <gnuplot-beta@lists.sourceforge.net>

      Compile options:
      +READLINE  -LIBREADLINE  +HISTORY  +BACKWARDS_COMPATIBILITY  +BINARY_DATA 
      +GD_PNG  +GD_JPEG  +GD_GIF  +ANIMATION 
      -NOCWDRC  +X11  +X11_POLYGON  +MULTIBYTE  +USE_MOUSE  +HIDDEN3D_QUADTREE 
      +DATASTRINGS  +HISTOGRAMS  +OBJECTS  +STRINGVARS  +MACROS  +IMAGE 

      DRIVER_DIR     = "/usr/local/libexec/gnuplot/4.1"
      GNUPLOT_PS_DIR = "/usr/local/share/gnuplot/4.1/PostScript"
      HELPFILE       = "/usr/local/share/gnuplot/4.1/gnuplot.gih"

      Please advice.

      Thanks.

       
    • Hans-Bernhard Broeker

      You don't have +GD_TTF in the list of compile options.  The reason why configure didn't find it will be in your config.log.

       

Log in to post a comment.