no matching function for call to GDLGStream

Help
2011-10-17
2013-06-03
  • Daniel Molina

    Daniel Molina - 2011-10-17

    I'm trying to compile gdl.

    'make' returns me this:

    In file included from graphics.hpp:50:0,
                     from gdleventhandler.cpp:28:
    gdlgstream.hpp: In constructor ‘GDLGStream::GDLGStream(int, int, const char*, const char*)’:
    gdlgstream.hpp:53:82: error: no matching function for call to ‘GDLGStream::string(const char )’
    /home/guest/My_Programs/include/plplot/plstream.h:851:10: note: candidate is: void plstream::string(PLINT, const PLFLT*, const PLFLT*, const char*)
    gdlgstream.hpp: In static member function ‘static bool GDLGStream::checkPlplotDriver(const char*)’:
    gdlgstream.hpp:106:41: error: no matching function for call to ‘GDLGStream::string(const char*&)’
    /home/guest/My_Programs/include/plplot/plstream.h:851:10: note: candidate is: void plstream::string(PLINT, const PLFLT*, const PLFLT*, const char*)
    gdlgstream.hpp:114:67: error: no matching function for call to ‘GDLGStream::string(const char*&)’
    /home/guest/My_Programs/include/plplot/plstream.h:851:10: note: candidate is: void plstream::string(PLINT, const PLFLT*, const PLFLT*, const char*)
    make: ***  Error 1
    make: Leaving directory `/home/guest/Compiling/gdl-0.9.1/src'
    make: ***  Error 1
    make: Leaving directory `/home/guest/Compiling/gdl-0.9.1/src'
    make: ***  Error 1
    make: Leaving directory `/home/guest/Compiling/gdl-0.9.1'
    make: ***  Error 2

    Help.

     
  • Alain C.

    Alain C. - 2011-10-17

    could you give more informations ? Which OS and version ?
    Are you using the current TGZ, or the CVS version ? which plplot version ? We do have a problem with some intermediate plplot versions (after 5.5 and before 5.9), it may be better to try with recent plplot.

    Alain

     
  • Daniel Molina

    Daniel Molina - 2011-10-17

    Very quick answers. Thank you very much!

    Trisquel 5.0 (based on Ubuntu 11.04), last  stable version of gdl in a tar.gz (0.9.1), plplot 5.9.9.

     

Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:

JavaScript is required for this form.





No, thanks