IDL procedures not implemented yet

<< < 1 2 (Page 2 of 2)
  • Mark

    Mark - 2012-06-27

    Hi Guys,

    Thanks for your help.  As was suggested by Alain, I was able to get by the gsl by specifying the true path (/sw for Fink compile).  However, I then ran into a similar issue with plplot. 

    ./configure -with-gsldir=/sw -withplplotdir=/sw/lib/plplot

    I specified what appears to be the plplot library path (generated from Fink), but no luck (not really sure why).  

    I then tried to compile plplot from the tar ball following the suggested instruction above by Alain to see if I was pointing to the correct plplot libraries, but ran into an error doing the cmake for plplot.

    Any suggestions?

    Thanks again,

  • Mark

    Mark - 2012-06-27

    Note: The command in the previous message is :
    ./configure -with-gsldir=/sw -with-plplotdir=/sw/lib/plplot

    (I missed a "-" when putting it into the email).

  • Mark

    Mark - 2012-07-18

    Hi Guys,

    I was wondering if anyone has been successful at compiling the CVS GDL on OS_X 10.7? 

    I have compiled GDL 1:0.9.2 using Fink successfully on 10.7, but I am having when I go to configure the CVS version and get the following error:

    checking for gsl_ran_binomial_knuth in -lgsl… yes
    checking for cblas_drot in -lgslcblas… yes
    checking for plsexit in -lplplotcxxd… no

    Error! plplot library is required but was not found
           Use -with-plplot=DIR to specify the plplot directory tree

           (suitable Debian/Ubuntu packages: libplplot-dev, plplot9-driver-xwin)
           (suitable Fedora package: plplot-devel)

    I have plplot 5.9.6-3 libraries in my fink /sw/lib/plplot/  directory.  I tried pointing to this directory with:

    ./configure -with-gsldir=/sw -with-plplotdir=/sw/lib/plplot/

    However, it still says that it cannot find the plplot directory.

    This is frustrating as I have GDL 1:0.9.2-3 working fine compiled using Fink, but I cannot get the CVS version with the newest updates to compile.  Is anyone else pointing to a plplot library compiled using Fink?

    Any help would be very much appreciated.



  • Mark

    Mark - 2012-07-19

    Ok.  I figured out the directory issue looking through the config.log file again. It appears that when setting the "-with-plplotdir" it adds and extra "lib" to the end of the directory path.  For example : /sw/lib/plplot becomes /sw/lib/plplot/lib.  Since Fink puts the libraries in the "plplot" directory under the "lib" directory it cannot find the libraries.  Therefore, if pointing libraries generated under Fink one needs to create another directory or link so that the libraries are under a "lib directory as this appears to be what is expected with these config options.


<< < 1 2 (Page 2 of 2)

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:

No, thanks