Problems installing GDL on Mac OS X Lion

  • Lukasz Wyrzykowski

    I failed to install the GDL on my Mac with Lion. Tried both MacPorts and source unsuccessfully.

    1. port gives this error:
    -->  Verifying checksum(s) for cmsvlib
    Error: Checksum (rmd160) mismatch for cmsvlib.tar.gz
    Error: Checksum (sha256) mismatch for cmsvlib.tar.gz
    Error: org.macports.checksum for port cmsvlib returned: Unable to verify file checksums

    I found that this was a known bug in 2010, but I'm now running version 2.1.2 of Macports and still get this.

    2. source:
    I was trying to compile it in 64bits and had all required libraries in arch x86_64. I even ensured all the flags were indicating 64bits arch:
    ./configure CFLAGS="-arch x86_64" CPPFLAGS="-arch x86_64" LDFLAGS="-arch x86_64" -with-gsldir=/opt/local/ -with-plplotdir=/opt/local/

    but still, at some point the linker wanted to do it in 32 bits. Config.log file revealed attempt of compilation with g++ with both flags: -arch x86_64 (enforced by me) and -arch i386 in the same command. As far as I could understand what is going on in the configure file, I found that this is set in the LIB variable, but I couldn't find where. Is it some bug in the configure or I'm doing something wrong?

    Many thanks for your help!

  • Lukasz Wyrzykowski

    Hi again,

    I have solved eventually the option 2 (source) in the following way:

    I switched off most of the extras, like ImageMagick, python, netcdf, hdf, wxWidgets and pslib:

    ./configure CC=gcc-4.7 CXX=g++-4.7 CFLAGS="-arch x86_64" CPPFLAGS="-arch x86_64" CXXFLAGS="-arch x86_64" LDFLAGS="-arch x86_64" -with-gsldir=/opt/local/ -with-plplotdir=/opt/local/ -with-Magick=no -with-python=no -with-netcdf=no -with-hdf=no -with-hdf5=no -with-wxWidgets=no -with-pslib=no

    and used different gcc and g++ compilers, not LLVM (which are the only available on Mac10.7), see hints:!msg/abyss-users/N9r8LyAaju0/yY0UsHs1NQ0J

    This eventually led to a working version of GDL!!

    A note: with pslib included (from MacPorts) I had a following error when starting gdl:
    Symbol not found: _libintl_setlocale
    Referenced from: /opt/local/lib/libps.0.dylib

    that's why I had to switch off the libps from the configuration.

    It would be great if somebody could suggest solutions how to compile the gdl fully.



Log in to post a comment.