Issue on Mac when running make

ckt
2013-10-10
2013-10-11
  • ckt

    ckt - 2013-10-10

    Finally have gotten to the point of running make for GDL, but I received this message below. Couldn't find anything online to help me, any suggestions appreciated, thank you.

    ckt

    In file included from plotting.cpp:25:
    In file included from ./dinterpreter.hpp:57:
    ./GDLInterpreter.hpp:651:9: warning: add explicit braces to avoid dangling else [-Wdangling-else]
    else
    ^
    plotting.cpp:1894:8: error: no member named 'wid' in 'GDLGStream'
    a->wid(charthick);
    ~ ^
    plotting.cpp:1922:8: error: no member named 'wid' in 'GDLGStream'
    a->wid(static_cast<PLINT>(floor(thick-0.5)));
    ~ ^
    plotting.cpp:2591:54: warning: data argument not used by format string [-Wformat-extra-args]
    snprintf(label, length, ((ptr->isLog)?"1":"0"),value);
    ~~~ ^
    plotting.cpp:2591:54: warning: data argument not used by format string [-Wformat-extra-args]
    snprintf(label, length, ((ptr->isLog)?"1":"0"),value);
    ~~~ ^
    plotting.cpp:2939:12: error: no member named 'wid' in 'GDLGStream'
    a->wid(Thick);
    ~ ^
    plotting.cpp:2984:10: error: no member named 'wid' in 'GDLGStream'
    a->wid(1);
    ~ ^
    plotting.cpp:3127:12: error: no member named 'wid' in 'GDLGStream'
    a->wid(Thick);
    ~ ^
    plotting.cpp:3152:10: error: no member named 'wid' in 'GDLGStream'
    a->wid(1);
    ~ ^
    3 warnings and 6 errors generated.
    make[1]: [gdl-plotting.o] Error 1
    make:
    [all-recursive] Error 1

     
  • Alain C.

    Alain C. - 2013-10-11

    Thanks for the feedback.

    1/ It seems you are using clang, isn't it ? Which version ? Before delivering 0.9.4 we tried to cleanup all errors and some warnings for clang.

    2/ are you using the last 0.9.4 ?

    3/ which version of plplot are you using ?

    We will try to correct your pbs in the CVS.

    Alain

     
    Last edit: Alain C. 2013-10-11
    • ckt

      ckt - 2013-10-11

      Thank you for responding, I appreciate it. As for your questions:

      (1) If I'm using clang, I don't know it. The message above was generated when I ran make. The actual compile statement (which was displayed prior to the message above) was:

      g++ -DHAVE_CONFIG_H -I. -I.. -I/Users/ckt/GDL/readline-master/Compilation/include -I/Users/ckt/GDL/readline-master/Compilation -I/Users/ckt/GDL/gsl-1.16/Compilation/include -I/Users/ckt/GDL/plplot-5.9.10/Compilation/include -I/Users/ckt/GDL/libproj4/include -g -O2 -MT gdl-plotting.o -MD -MP -MF .deps/gdl-plotting.Tpo -c -o gdl-plotting.o test -f 'plotting.cpp' || echo './'plotting.cpp

      (2) In reference to the "last 0.9.4", I I believe I downloaded from this link:

      http://sourceforge.net/projects/gnudatalanguage/files/gdl/0.9.4/gdl-0.9.4.tar.gz/download

      (3) I am using plplot-5.9.10

      Again, thank you...

      ckt

       
  • Alain C.

    Alain C. - 2013-10-11

    I just tested to compile to the end with success on Ubuntu 12.04, plplot 5.9.9 and clang 3.0

    Alain

     
  • giloo

    giloo - 2013-10-11

    Hi and welcome to the joys of plplot. Your configuration includes the latest plplot library (plplot.5.9.10) and 'they' have removed the 'wid' function, breaking the backwards-compatibility that everyone would normally expect from a library.
    We have modified the GDL code to support plplot.5.9.10 but afaik this is only in the cvs at the time. You could get the last cvs version (note: cvs 'snapshots' may sometimes not compile) or install plplot.5.9.9 which will enable to compile gdl 0.9.4 correctly.

     
    • ckt

      ckt - 2013-10-11

      Ok, thanks... I noticed that in plplot, there is a width function. Is that by chance the same thing as wid (plstream.cc)?

       
  • giloo

    giloo - 2013-10-11

    yes and no, since width() takes a PLFLT as argument, and wid() a PLINT. And there are others incompatibilities as well.
    0.Poplawski was first to notice that and he provided the follwing patch (attached).

    note that you need to remove CMakeChache.txt and config.h, then run cmake again in order to recompile correctly after applying the patches.

     
    Attachments
    • ckt

      ckt - 2013-10-11

      Sorry, saw your reply after installing plplot.5.9.9. This time, I think I got further along, but more issues upon running the GDL Makefile:

      duplicate symbol _overloadOperatorNames in:
      gdl-overload.o
      duplicate symbol Z24OverloadOperatorIndexFunSs in:
      gdl-overload.o
      duplicate symbol
      Z24OverloadOperatorIndexProSs in:
      gdl-overload.o
      duplicate symbol Z22ThrowFromInternalUDSubP6EnvUDTRKSs in:
      gdl-overload.o
      duplicate symbol
      Z26_GDL_OBJECT_OverloadIsTrueP6EnvUDT in:
      gdl-overload.o
      duplicate symbol Z36_GDL_OBJECT_OverloadBracketsLeftSideP6EnvUDT in:
      gdl-overload.o
      duplicate symbol
      Z37_GDL_OBJECT_OverloadBracketsRightSideP6EnvUDT in:
      gdl-overload.o
      duplicate symbol Z24_GDL_OBJECT_OverloadEQOpP6EnvUDT in:
      gdl-overload.o
      duplicate symbol
      Z24_GDL_OBJECT_OverloadNEOpP6EnvUDT in:
      gdl-overload.o
      duplicate symbol Z42_GDL_OBJECT_OverloadReportIllegalOperationP6EnvUDT in:
      gdl-overload.o
      duplicate symbol
      Z24SetupOverloadSubroutinesv in:
      gdl-overload.o
      ld: 11 duplicate symbols for architecture x86_64
      clang: error: linker command failed with exit code 1 (use -v to see invocation)
      make[3]: [gdl] Error 1
      make[2]:
      [all-recursive] Error 1
      make[1]: [all-recursive] Error 1
      make:
      [all] Error 2

      Any ideas appreciated, in the meantime, I will see if I can figure out anything.

      ckt

       
  • giloo

    giloo - 2013-10-11

    wow.
    Now that's too far from my guruness...
    I suggest recompiling everything from a fresh gdl.0.9.4 download.

     
    • ckt

      ckt - 2013-10-11

      Will do. By the way, I noticed that I had to generate a .configure file, though the INSTALL instructions seem to indicate one should already exist, so based upon the INSTALL instructions, I ran autoreconf -i and received this output:

      $ autoreconf -i
      aclocal: warning: autoconf input should be named 'configure.ac', not 'configure.in'
      aclocal: warning: couldn't open directory 'm4': No such file or directory
      libtoolize: putting auxiliary files in .'. libtoolize: copying file./ltmain.sh'
      libtoolize: putting macros in AC_CONFIG_MACRO_DIR, m4'. libtoolize: copying filem4/libtool.m4'
      libtoolize: copying file m4/ltoptions.m4' libtoolize: copying filem4/ltsugar.m4'
      libtoolize: copying file m4/ltversion.m4' libtoolize: copying filem4/lt~obsolete.m4'
      libtoolize: Consider adding -I m4' to ACLOCAL_AMFLAGS in Makefile.am. libtoolize:AC_PROG_RANLIB' is rendered obsolete by `LT_INIT'
      aclocal: warning: autoconf input should be named 'configure.ac', not 'configure.in'
      automake: warning: autoconf input should be named 'configure.ac', not 'configure.in'
      configure.in:43: installing './compile'
      configure.in:43: installing './config.guess'
      configure.in:43: installing './config.sub'
      configure.in:38: installing './install-sh'
      configure.in:38: installing './missing'
      automake: warning: autoconf input should be named 'configure.ac', not 'configure.in'
      src/Makefile.am:2: warning: 'INCLUDES' is the old name for 'AM_CPPFLAGS' (or '_CPPFLAGS')
      src/Makefile.am: installing './depcomp'
      src/antlr/Makefile.am:1: warning: 'INCLUDES' is the old name for 'AM_CPPFLAGS' (or '
      _CPPFLAGS')
      parallel-tests: installing './test-driver'

      I may need to take a break from this today, I feel like I'm missing something obvious but can't pin it down.

      ckt

       

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:





No, thanks