SourceForge has been redesigned. Learn more.

symbol lookup error

  • Katerine

    Katerine - 2012-04-18

    I have been trying to install gdl on a linux mint machine, and it appears to have been successful. But, when I try to run it by typing 'gdl' I get the following error:

    gdl: symbol lookup error: /usr/local/lib/ undefined symbol: UP

    As far as I can tell I have the most recent versions of gdl and readline and have tried searching online for information but have found nothing particularly helpful.

    I'm also not very familiar with linux only having used it at university where everything was nicely set up for me so I apologise if this post is not relevant.

    Thanks for any help you can give me.  :)

  • Sylwester Arabas


    Have you installed a packaged version of gdl? Which distribution?

    Google suggests you might be using a very fresh (precise?) Ubuntu distribution where the newest libreadline package is not compatible with other slightly older packages… but that's just a guess. If that's the case, you could try downgrading libreadline or installing gdl from source.


  • Katerine

    Katerine - 2012-04-18

    I installed gdl using: sudo apt-get install gnudatalanguage and so I'm assuming its version 0.9.2. I did initially try installing gdl using the make files etc but I got the same error and so removed it and tried it this way.

    Yes it's linux mint 12 (Lisa), but i'm not sure how to downgrade libreadline? I had installed libreadline6-dev and have now removed it but is still there…

    Sorry if I'm being very stupid here. I appreciate your help thanks.

  • Sylwester Arabas

    Apparently there's no problem on GDL side, and hence it's difficult to help.
    If I get the problem right, there's some issue with readline package in your distro - perhaps please try asking there.

    I don't know the most elegant way of downgrading packages in Debian/Ubuntu distros, but you can always download a particular .deb file with the version you want to try, and simply try "double clicking" on it - probably there'll be some GUI suggesting you what to do in such case…

    Here's a link for downloading a slightly older libreadine package from Ubuntu - perhaps you could try with it:


  • ccplusplus support

    is your problrm solved.
    I also got the same error after installing the gdl-0.9.2 and the latest readline using apt-get as you did. Please suggest me too how to get rid of that. I have given enough time in installing gdl now can't roll back.


Log in to post a comment.