#6 problem building GDL

closed
nobody
None
5
2004-09-14
2004-09-08
No

Hi,
I'm trying to build GDL on debian sid. I'm getting an
error when it tries to make magick_cl.o. Also, when I
build --without-Magick, it builds OK, but won't output
plots to Xwin - does it need imagemagick to do that?
Incidentally, I also had problems with hdf, which I
fixed by setting CPPFLAGS to -I/usr/include/hdf. This
seems to be something configure and make should also be
able to figure out.
Anyway, I've attached the build.log file for magick_cl.o
thanks,
Maurice

Discussion

  • Maurice Leutenegger

    build log for magick_cl.o

     
  • Joel Gales

    Joel Gales - 2004-09-08

    Logged In: YES
    user_id=958613

    Try commenting out the following line in magick_cl.cpp

    //#include <Magick++.h>

    Use should also specify the location of the HDF root
    directory using

    "--with-hdf=DIR" with configure.

    Joel Gales

     
  • Joel Gales

    Joel Gales - 2004-09-08

    Logged In: YES
    user_id=958613

    Try commenting out the following line in magick_cl.cpp

    //#include <Magick++.h>

    Use should also specify the location of the HDF root
    directory using

    "--with-hdf=DIR" with configure.

    Joel Gales

     
  • Joel Gales

    Joel Gales - 2004-09-08

    Logged In: YES
    user_id=958613

    Try commenting out the following line in magick_cl.cpp

    //#include <Magick++.h>

    Use should also specify the location of the HDF root
    directory using

    "--with-hdf=DIR" with configure.

    Joel Gales

     
  • Maurice Leutenegger

    Logged In: YES
    user_id=1117857

    Hi Joel,

    thanks, this works. however, I still have the problem where
    it won't plot to xwin -- I thought having imagemagick would
    fix this, but I guess that wasn't the problem.

    If I do plot,[0,1],[0,1] I get the error message:

    Requested device xwin not available.

    Then, it just sits there. If I try to enter keyboard
    commands, depending on what I enter, it has some kind of
    broken error handling sequence - it wants to ask me for a
    different output device, and for a filename to output to.
    But it prints the output asking the question after the
    keyboard input answering, and it invariably seg faults in
    the end.

    If I first do set_plot,'ps' and then plot something, it
    works fine.

    thanks for the help,

    Maurice

     
  • Marc Schellens

    Marc Schellens - 2004-09-09

    Logged In: YES
    user_id=932957

    Graphical output is completely independent from ImageMagick.

    "Requested device xwin not available"
    is an error message from plplot.
    You need at least version 5.3

    Please check you plplot installation.

    HDH,
    Marc

     
  • Maurice Leutenegger

    Logged In: YES
    user_id=1117857

    Yes, you are right. I had plplot 5.3.1 installed, but not
    the xwin driver. This is why it compiled correctly, but had
    problems outputting to xwindows.

    thanks for all the help,
    Maurice

     
  • Marc Schellens

    Marc Schellens - 2004-09-14
    • status: open --> closed
     

Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:

JavaScript is required for this form.





No, thanks