#435 OPENR/W doesn't protect white spaces in FILENAME

open-invalid
nobody
None
8
2011-11-16
2011-11-07
No

GDL> filename=DIALOG_PICKFILE(/READ, PATH='/home/lluvia/Imágenes')
GDL> print, filename
/home/lluvia/Imágenes/Lina camara/PICT0494.JPG
GDL> READ_JPEG, filename, image
% READ_JPEG: Error opening file. File: /home/lluvia/Imágenes/Lina camara/PICT0494.JPG
% Error occurred at: READ_JPEG 87 /home/lluvia/My_Programs/share/gnudatalanguage/lib/read_jpeg.pro
% SHOW_IMAGE 160 show_image.pro
% DISPLAY_IMAGE 52 display_image.pro
% $MAIN$
% Execution halted at: SHOW_IMAGE 160 show_image.pro
GDL> READ_JPEG, '/home/lluvia/Imágenes/Lina\ camara/PICT0494.JPG', image
GDL>

Discussion

  • Alain C.

    Alain C. - 2011-11-08
    • priority: 5 --> 8
    • summary: dialog_pickfile doesn't protect white spaces --> OPENR/W doesn't protect white spaces in FILENAME
     
  • Alain C.

    Alain C. - 2011-11-08

    the problem is not related to DIALOG_PICKFILE, but to the fact that whitespaces in FILENAME are protected before using OPENR/W

    That is a critical problem ! Thanks !

     
  • Alain C.

    Alain C. - 2011-11-08

    In fact, this important bug goes back to WordExp().

    Marc did prepared a patch, should be apply today in the CVS.

     
  • Alain C.

    Alain C. - 2011-11-09

    now available in the CVS. Please open a new bug report if a similar effect is discovered (pb with escaping special chars [e.g.: white space, *, ~, ?] in filenames and paths)

    Who has an idea to include a test on that in the testsuite ?

     
  • Alain C.

    Alain C. - 2011-11-09
    • status: open --> closed-fixed
     
  • Alain C.

    Alain C. - 2011-11-16
    • status: closed-fixed --> open-invalid
     
  • Alain C.

    Alain C. - 2011-11-16

    not solved, side effects discovered.

    sorry

    Alain

     

Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:





No, thanks