Can't connect to POP3

  • Kristian

    Kristian - 2005-03-03

    I have no clue whatsoever where the problem lies, but I just can't get gnubiff to connect to a POP account.

    I've tried with three (3!) different pop accounts; all of them are on different servers than the others. I've tried alternating settings, but nothing seems to help. *The same settings work fine in other mail-checkers (such as mail-notification, kbiff, and some other one I can't remember the name of) and mail-programs (such as Thunderbird).*

    I've tried three different versions of gnubiff, on two different computers: a debian computer, and a gentoo. I've tried the default versions in each dist. (v2.0.2 in gentoo; don't remember which version in debian). I've also tried to download, and compile, the source. *Nothing changed.*

    I can, however, successfully connect to IMAP-accounts...

    It seems strange to me that all other programs can connect to the POP-accounts, and that gnubiff can connect to the IMAP-ones, but not to a single one of the POP:s.

    Since this is such a fundamental error, and an error that seems to span several versions, I just can't imagine this is caused by a bug in gnubiff, but rather that there should be something I can do, some setting I'm continously missing, but I just can't figure out what.

    Can you?

    • Robert Sowada

      Robert Sowada - 2005-03-07


      Can you send a copy of a gnubiffrc file that causes this problem (make sure to remove any password related data before)? Also you could compile gnubiff with debugging enabled (configure --debug) and send us the output.

      CU Robert :-)

    • Kristian

      Kristian - 2005-03-13

      I'll put up both the gnubiffrc and debug messages as soon as I can (since it doesn't seem possible to attach files here), however I doubt they will help.

      The gnubiffrc is "freshly created", so to speak. That is, it's what gnubiff creates, the only thing I've changed is the mailserver settings. And I've done that *many* times. Anyway, there shouldn't be any quirks in the setup. It's as close to the default as can be, after the mailserver-settings are set.
           And the debug messages aren't telling me anything new (after I enabled debug with configure). It scrolls through trying to open mailbox, being unable, and trying with another port. I've let it do that for a long time; no luck. I've tried manually setting it. Still no luck. Really weird. It seems like gnubiff simply can't communicate with this particular server...

      But another (POP) server suddenly works, (which I complained about not working in my earlier post,) so the problem seems to prevail only with one of the servers, so perhaps, in some mysterious way, the problem lies with the server?
           Though that does seem a bit unprobable? Since no other programs are having problems?
           The server is; when pinging it, it's found at "", but surely that shouldn't matter? (I've tried setting the server "straight to" as well, but that didn't seem to make a difference.)

    • Robert Sowada

      Robert Sowada - 2005-03-13

      There seems to be no problem with on port 110:
      nc 110
      +OK POP3 Ready kyyhky1 0001d96c
      +OK QUIT

      Do you use any of the autodetection features of gnubiff? Perhabs this causes problems: This server seems to support IMAP too. Does it help to select the POP protocol and the prefered authentication method (USER/PASS, APOP or SSL)?

      If attaching files to messages here causes problems you can mail to or to

    • Kristian

      Kristian - 2005-03-16

      *Sigh.* You know how sometimes you only need to ask somebody, for something to work out as it should? Not that you necessarily understand how or why it works, but it does. Well it does.

      Sorry to take up your time!

      I do try to cover all other options before I start to ask questions, but... Well this time it seems I didn't do that properly.

      The problem might have been how it "logs in" to the mail-server. It's now set to what seems to work. It might be that I didn't go through those options enough. I did try to do this earlier on as well, but thought I saw that the errors kept scrolling through all possible settings. Even now, after it was set  correctly, I still got `can't open --- at port ---', and then it kept repeating that for different ports, even though it already had checked the mail (successfully).

      I tried to re-create this behaviour, aftera restart of gnubiff, but of course couldn't. So at this moment I'll just have to assume that gnubiff was doing what I told it to do, but the `instructions' were perhaps less than great. ;)


Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:

JavaScript is required for this form.

No, thanks