#57 Missing requirement during install

Version 1.x
closed
3
2014-12-25
2014-05-27
No

Hello,

I am trying to update GNU ARM Eclipse plugins from version 0.5.4 to the current one through
the update site http://gnuarmeclipse.sourceforge.net/updates.
I am especially interested in the j-link support.

I am having this problem related to bundle org.eclipse.debug.ui 3.9.0, and similar errors for the other parts (other than j-link debugger):

Cannot complete the install because one or more required items could not be found.

Software being installed: GNU ARM J-Link Debugging Support 1.5.1.201404240550 (ilg.gnuarmeclipse.debug.gdbjtag.jlink.feature.group 1.5.1.201404240550)
Missing requirement: GNU ARM J-Link Debugging Support 1.5.1.201404240550 (ilg.gnuarmeclipse.debug.gdbjtag.jlink 1.5.1.201404240550) requires 'bundle org.eclipse.debug.ui 3.9.0' but it could not be found
Cannot satisfy dependency:
From: GNU ARM J-Link Debugging Support 1.5.1.201404240550 (ilg.gnuarmeclipse.debug.gdbjtag.jlink.feature.group 1.5.1.201404240550)
To: ilg.gnuarmeclipse.debug.gdbjtag.jlink [1.5.1.201404240550]

I even tried to uninstall gnuarm eclipse 0.5.4 before updating.

Old version 0.5.4 was working fine.

I am using Eclipse Juno
Version: Juno Service Release 2
Build id: 20130225-0426

Operating system is Windows XP

Toolchain is GNUARM 4.1.

Any hint?
Many thanks in advance.

Discussion

  • Liviu Ionescu (ilg)

    Any hint?

    yes, update to Eclipse Kepler and retry.

     
  • supermariopros

    supermariopros - 2014-05-28

    OK, updated to Kepler and it works now, thank you!

     
  • Liviu Ionescu (ilg)

    great! can we close this ticket now?

     
  • supermariopros

    supermariopros - 2014-05-29

    Yes, we can close it.

     
  • Liviu Ionescu (ilg)

    • status: open --> closed
    • assigned_to: Liviu Ionescu (ilg)
     

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:





No, thanks