Unable to compile Gnofract4d under Solaris10

Help
Sergio
2005-05-21
2013-03-19
  • Sergio

    Sergio - 2005-05-21

    The problem is that setup.py, via os.path.walk, need under Solaris the proprietary Force C and C++ compilers...

    But under Linux, gcc and g++, or gcc and c++ can fine compile the whole project.

    Is there any way to deviate os.path.walk to gcc/g++ ?

    (We have gcc/g++ under Solaris, but it's not easy to know what is exactly in os.path.walk)

    Thank's !

    Best regards.

    Sergio

     
    • Edwin Young

      Edwin Young - 2005-05-21

      Hi,

      I don't know why that particular function should require a proprietary compiler, that sounds really odd - all it does is look recursively through a directory tree.

      You could try one of 2 things:

      1) download Python source & compile it using gcc.
      2) comment out the last line in setup.py and do it manually:
      - run setup.py build
      - find fract4dc.so and fract4d_cmap.so under the build dir, and copy them to the fract4d dir
      - find fract4dguic.so and copy to the fract4dgui dir.

       
    • Sergio

      Sergio - 2005-05-23

      Thank's for the immediate help !

      But...

      - I've now installed Python2.3 in another directory (opt/csw) ;
      - Setup.py invoke /usr/bin/env python, where the first version of Python is originally installed, and probabily compiled with
      Force C. And under /opt/csw i don't have a env file !

      I think that all commands os.environ.get, os.execv ... are invoking the first originally installed Python, and launching the Sun Force C compiler, what i don't have. If i simule and redirect this launching to gcc/g++, this can't work, because it need an option -pentium, what not exist in gcc/g++.

      Complex !

      I mean that the one solution is to invoke gcc/g++ (only for the compilation) directly from setup.py, but i don't see how.

      If you have any idea...

      Thank's.

      Sergio.

       
      • Edwin Young

        Edwin Young - 2005-05-23

        I think you just need to modify your path so your version of Python is found first.

        try export PATH=/opt/csw;$PATH
        then run ./setup.py build

        Alternatively you can change the first line of setup.py (and gnofract4d) to point to your alternate location: just change

        #!/usr/bin/env python

        to

        #!/opt/csw/python

         
    • Sergio

      Sergio - 2005-05-23

      It works ! And the fractals looks good !

      Only these from Orgform can't we turn, but only displace.

      For all others (fract4d, fractint, news) it's all OK.

      I only searched a env file, and not a python executable !
      It has fine worked with #!/opt/csw/bin/python.

      Thank you very much !

      Sergio

       

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:





No, thanks