Problem in Fedora core 6

  • Salamandra001

    Salamandra001 - 2006-11-24

    I have a standard instalation of i686 FC6 on a laptop. I installed Gnofract4d via yum. When Ii try to execute i get this:

    Traceback (most recent call last):
      File "/usr/bin/gnofract4d", line 47, in ?
        from fract4dgui import main_window, preferences, utils
      File "/usr/lib/gnofract4d-2.14/fract4dgui/", line 15, in ?
        from fractutils import flickr
      File "/usr/lib/gnofract4d-2.14/fractutils/", line 244, in ?
        def encode_multipart_formdata(fields, files, BOUNDARY = '-----'+mimetools.choose_boundary()+'-----'):
      File "/usr/lib/python2.4/", line 130, in choose_boundary
        hostid = socket.gethostbyname(socket.gethostname())
    socket.gaierror: (-2, 'Name or service unknown')

    Does someone knows why this happens?

    • Edwin Young

      Edwin Young - 2006-11-26


      This is an issue which can occur if /etc/hosts isn't set up the way the Python standard library expects it. I think the bug is really in either Python or Fedora, but this will be worked around in the next release.

      The simplest fix in the meantime is to edit fractutils/ to change mimetools.choose_boundary() to "xxxxxxxxxxxxxxx".

      Sorry for the inconvenience!

    • Salamandra001

      Salamandra001 - 2006-11-27

      Thanks for the reply. I'll try when i get home.
      I have to add that Gnofract worked flawlessly in Fedora 4 and 5. Then in one update stopped working, and keeps the same in Fedora core 6. Just if it helps you.

      You don't have to apologize, thank you for your efforts and your software!!

    • Salamandra001

      Salamandra001 - 2006-11-27

      Could you give more detailed instructions?

      I have put xxxxxxxxxxxxxxx into the brackets, then removed mimetools.choose_boundary()then...

      I can't get it to work.

      I don't know anything of python!!!

      Thanks for your patience.

    • Edwin Young

      Edwin Young - 2006-11-28

      Sorry, that was a bit obscure. Try this:

      Save this file:\*checkout*/gnofract4d/gnofract4d/fractutils/

      on top of fractutils/

      That should do it. (The file is the most recent version, which will be in the next release.)

    • Salamandra001

      Salamandra001 - 2006-11-30

      I replaced with the one you provided and now i get:
      Traceback (most recent call last):
        File "/usr/bin/gnofract4d", line 239, in ?
        File "/usr/bin/gnofract4d", line 148, in main
          mainWindow = main_window.MainWindow()
        File "/usr/lib/gnofract4d-2.14/fract4dgui/", line 65, in __init__
          self.f = gtkfractal.T(self.compiler,self)
        File "/usr/lib/gnofract4d-2.14/fract4dgui/", line 461, in __init__
        File "/usr/lib/gnofract4d-2.14/fract4dgui/", line 75, in __init__
        File "/usr/lib/gnofract4d-2.14/fract4dgui/", line 88, in try_init_fractal
        File "/usr/lib/gnofract4d-2.14/fract4d/", line 743, in compile
        File "/usr/lib/gnofract4d-2.14/fract4d/", line 157, in compile_all
          outputfile = os.path.abspath(self.generate_code(t, cg))
        File "/usr/lib/gnofract4d-2.14/fract4d/", line 267, in generate_code
          raise fracttypes.TranslationError(

      Just trying to help you to get it working in Fedora.

    • Catenary

      Catenary - 2006-12-04


      I've just tried out Gnofract4D on Fedora Core 6 and haven't seen this problem, so I'm not sure exactly what's up. It probably indicates that you don't have some package installed which is required to run the C++ compiler. You could try downloading the source package (the .tar.gz file) and compiling that - if you run into problems doing that, it'll probably indicate what the problem is at runtime.

    • Salamandra001

      Salamandra001 - 2006-12-04

      Ok, i'm working now, i will see to it and post back.


    • Salamandra001

      Salamandra001 - 2006-12-04

      Solved installing the gcc, in fact installing several development tools. Anyway i think they should have been installed by yum via dependencies.

      THANK YOU.


Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:

No, thanks