gnofract4d on ubuntu 9.04 Jaunty

Help
2009-05-24
2013-03-19
  • Lluisa Nunez

    Lluisa Nunez - 2009-05-24

    Hi,
    I've been a user of gnofract4d since I was with Fedora 4. Last time, on Ubuntu Intrepid, I managed to install the rpm with alien.
    Now I'm having problems because the rpm is no longer valid and when I try to install the Ubuntu .deb file, I get his message:

    lluisa@xcube:/media/disk/downloads$ sudo gdebi gnofract4d_3.10-1ubuntu1_i386.deb

    Reading package lists: Done
    Reading state information: Done
    Reading state information: Done
    Reading state information: Done
    Reading state information: Done
    This package is uninstallable
    Dependency is not satisfiable: python (<< 2.6)

    But I have python 2.6.2 installed. Any help?

     
    • Catenary

      Catenary - 2009-05-25

      Gnofract4D contains a binary python extension, and these binaries are only compatible with one version of python. Because Ubuntu versions up until 9.04 have been using Python 2.5, that's the python version I've been using. I will need to start building a separate binary package for python 2.6, which should be included in the next release.

      Until then, I suggest downloading the .tar.gz source package and compiling it. It's pretty easy, see the wiki.

       
    • Lluisa Nunez

      Lluisa Nunez - 2009-05-26

      Thanx, I will

       
    • Catenary

      Catenary - 2009-05-31

      I have now released 3.12, which includes a binary package which should be suitable for Ubuntu 9.04. Look for -python26- in the package name

       
    • Lluisa Nunez

      Lluisa Nunez - 2009-05-31

      I already have it installed. Everythig works fine. I've been trying Xaos and Fractive, but Gnofrac4d is the best
      Thank You!

       

Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:

JavaScript is required for this form.





No, thanks