When Downloading the tarball and converting it, or downloading the deb to install, the software center detects both ad bad quality and warns user.
file containing all quality-related errors when installing.
Alex, I need to ask you a couple of things before I can accept this as our bug:
1) What Linux distribution are you using? just saying "Natty" is fairly meaningless to me - is it the newest Ubuntu?
2) Where are you getting the tarball/deb to install - are you getting it via your distribution or via sf.net?
Yes, i am currently using natty narwhal (11.04) and i believe that this bug is only isolated to 11.04. I also found that it will not install from a deb on 11.04 because it asks for python 2.7, which SHOULD be irrelevant of the version.
And i am downloading both the deb and the tarball directly from it's sourceforge page.
Accepted that it needs to be fixed. I wouldn't call it a bug as such though as Gnofract4d still functions correctly even if this problem is not fixed, but will look into it.
The problem with your initial message was that it left me wondering where you were getting the files from as many distributions do make their own modifications to the source of packages before making their own packages for distribution to their users. Thanks for clearing that up that it is in fact our code triggering this warning.
The .deb is built for Lucid Lynx or so, so you will be being asked for an older Python than would normally come with Ubuntu - the tarball will sort that one - but we will be sticking to the 2.x series for the sec as that's what the extension parts are built and tested for.
I'll try and get this fixed for the 3.14 release that I'm working toward, but a word of warning: I will only be building the .deb on Lucid Lynx (32-, and maybe 64-, bit) so you are still better off getting the tarball and issuing a build/install to setup.py.
After double-checking things, although the .deb on the site should be free of the problem we were marked as "bad" for last time, there may still be problems with it - please could you check the new release on Natty Narwhal.
The dependency is still that Python >= 2.6 && < 3.0 is needed due to the platform I have available for making builds and trying to offer Gnofract4d from .deb to the widest possible number of users without forcing them to build from source or otherwise upgrade. I'm planning to make an extra two .deb releases next time around via Narwhal, though, so that people running Python >= 3.0 may run it without installing older Python versions first.
Log in to post a comment.
Sign up for the SourceForge newsletter:
You seem to have CSS turned off.
Please don't fill out this field.