Long PHP Parsing Tags Required?

Help
Ian Renton
2008-02-07
2013-04-03
  • Ian Renton

    Ian Renton - 2008-02-07

    I've just uploaded the gmail-lite files to my website, and run diagnose.php.  Test 9 ("short tags") fails, telling me to follow the directions in SERVER_HELP.  I can't find any such file, or in fact anything helpful with a Google search!

    There's also a couple of warnings in the output that don't seem to make tests fail.  diagnose.php-specific output quoted below, I'll post the rest of my phpinfo if necessary (short_open_tag in the phpinfo is indeed set to Off).  Server's not mine, so I can't touch the PHP install.

    Test 1 (safe mode): passed.

    Test 2 (curl extension): passed.

    Test 3 (curl http):
    Warning: curl_setopt() [function.curl-setopt]: CURLOPT_FOLLOWLOCATION cannot be activated when in safe_mode or an open_basedir is set in /usr/local/psa/home/vhosts/marmablue.co.uk/httpdocs/gl/diagnose.php on line 62
    passed.

    Test 4 (SSL via curl):
    Warning: curl_setopt() [function.curl-setopt]: CURLOPT_FOLLOWLOCATION cannot be activated when in safe_mode or an open_basedir is set in /usr/local/psa/home/vhosts/marmablue.co.uk/httpdocs/gl/diagnose.php on line 111
    passed.

    Test 5 (PHP session extension): passed.

    Test 9 (short tags): FAILED. Your server REQUIRES long php parsing tags. Please follow the directions in SERVER_HELP for 'Short Open Tags'. Either that, or you have to edit ALL of the gmail-mobile files...!

    If you have passed all tests, you should have no problem installing and using gmail-lite and libgmailer.

    The information below is for debugging or support.

     
    • neerav

      neerav - 2008-02-15

      Create a file called .htaccess in the gmail-lite directory.  Enter the following line and save:

      php_flag short_open_tag on

      That should do it.

      --
      Neerav

       
      • Ian Renton

        Ian Renton - 2008-02-15

        I suppose I should have thought of that, really! =p

        Just tried it, though, and I'm afraid it doesn't work.  Other .htaccess settings work fine, but seemingly nont that one.  Is it likely to be a restriction placed by the server admin?

         
        • neerav

          neerav - 2008-02-15

          If other flags in your .htaccess are working, then I doubt there is any restriction for this flag.  It's possible that instead of ON, it should be something similar like TRUE, or 1.  If your server is running as CGI, then you'll have to make a similar in a local php_ini file instead of .htaccess.

          Post your problem in the appropriate section of the help forum:  http://gmail.sayni.net/forum Others who may know better can also help.

          --
          Neerav

           
          • Ian Renton

            Ian Renton - 2008-02-15

            Thanks for the pointer, it turns out it is running the CGI version.  However, it's my host's policy not to let you change php.ini items!

            In the end, I just globally swapped "<?" for "<?php".  (Except the ones that are already <?php, anyway.)  Seems to do the trick =p

             

Log in to post a comment.