Linux and Lazarus

Help
Anonymous
2011-04-17
2013-03-15
  • Anonymous - 2011-04-17

    I can't get working latest GLScene with Lazarus  0.9.31:

    /usr/bin/ld: cannot find -lpthread
    /usr/bin/ld: cannot find -ldl
    /usr/bin/ld: cannot find -lc
    project1.lpr(20,1) Error: Error while linking
    project1.lpr(20,1) Fatal: There were 1 errors compiling module, stopping

    I guess still project isn't fully ported yet.

     
  • YarUnderoaker

    YarUnderoaker - 2011-04-18

    This look like  not GLScene error.
    But try add to uses for program
      {$IFDEF UNIX}{$IFDEF UseCThreads}
      cthreads,
      {$ENDIF}{$ENDIF}

     
  • Julio Cesar Pérez Franco

    I had just compiled and installed the glscene trunk version with lazarus 0.9.28.2
    I had to do some stuff:
    1. Commented an unsupported GTK+2 function to install the base glscene package.
    2. Install the Xfree86 development package (Xxf86vm specifically).
    2. Install Nvidia Cg stuff to install the shader package.
    3. Install the ODE library for the ODE package.
    4. Install the FMod SDK for the FMod package.
    5. Build and install as root since i still don't know how to enable it from regular user.

    Most of the steps were related to development libraries, but i can't figure out how to replace the GTK+ function.

     
  • Julio Cesar Pérez Franco

    I think maybe is because the access control in the library directory, maybe chmod to include access for that regular user.

     
  • YarUnderoaker

    YarUnderoaker - 2011-08-08

    I guess GLScene now compatible obly with lazarus 0.9.30.

     

Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:





No, thanks