Fullscreen, OpenGL Core 3.2 on OSX

Using GLFW
  • Anonymous - 2012-05-03

    I'm currently using GLFW as a base to build an engine on-top of.
    I have run into an issue when building on OSX Lion (Latest version and
    updates) when trying to run in fullscreen.
    The error is :
    2012-05-04 00:05:22.449 main invalid pixel format attribute
    2012-05-04 00:05:22.451 main NSMapGet: map table argument is NULL

    Anyone else got this ? Workarounds available ? or a fix in the works ?

    Thanks in advance.

  • Camilla Löwy

    Camilla Löwy - 2012-05-06

    Which version of GLFW are you using?

    Does fullscreen work despite the error? If not, what happens instead?

  • Anonymous - 2012-06-11

    I'm not the OP, but I'm getting the same error when using OpenGL 3.2 and
    fullscreen doesn't work.

  • Camilla Löwy

    Camilla Löwy - 2012-07-03

    This was a bug in GLFW. It has been fixed in 2.7.6, which will be coming out

  • Optic

    Optic - 2012-07-13

    I noticed that this was mentioned as fixed in 2.7.6 however I still seem to be
    experiencing the same issue still.

    With even the simplest of code :

    #include <iostream>
    #include <GL/glfw.h>
    int main()
        glfwOpenWindowHint( GLFW_FSAA_SAMPLES, 4 );
        glfwOpenWindowHint( GLFW_OPENGL_VERSION_MAJOR, 3 );
        glfwOpenWindowHint( GLFW_OPENGL_VERSION_MINOR, 2 );
        glfwOpenWindowHint( GLFW_OPENGL_FORWARD_COMPAT, GL_TRUE );
        glfwOpenWindow( 1280, 800, 24, 24, 24, 24, 8, 0, /*GLFW_WINDOW*/GLFW_FULLSCREEN );
        glfwSetWindowTitle( "Prototype-001" );
        printf("OpenGL Version : %s", glGetString(GL_VERSION));
        bool running = true;
        while( running )
            glClear( GL_COLOR_BUFFER_BIT );
            // Check if ESC key was pressed or window was closed
            running = !glfwGetKey( GLFW_KEY_ESC ) &&
            glfwGetWindowParam( GLFW_OPENED );
        return 0;

    It creates the same error :

    2012-07-13 13:19:54.873 main[17320:707] invalid pixel format attribute
    2012-07-13 13:19:54.874 main[17320:707] NSMapGet: map table argument is NULL
  • Optic

    Optic - 2012-07-13

    Ahha, Disregard the previous post, I seem unable to delete it.
    I believed I was running 2.6.7 however when printing the version out with :

    glfwGetVersion( &majVer, &minVer, &revVer );
        printf("Using GLFW Version : %i.%i.%i", majVer, minVer, revVer);

    It showed it wasn't actually using the latest version.

    I removed and reinstalled the files into /usr/local/… and it is now working


  • Camilla Löwy

    Camilla Löwy - 2012-07-13

    You had me worried there for a moment. Glad it works now :)


Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:

JavaScript is required for this form.

No, thanks