#12 problems with glLinkProgram

unknown
closed
nobody
None
5
2013-12-09
2010-12-23
Anonymous
No

I'm trying to determine why I'm hitting this unexplained thing:

<bdbdbd> GLSL ..
<bdbdbd> my vert and frags are compiling ok, but when it goes to link the linker dumps some garbage:
<bdbdbd> ShaderProgram:Link: Program log (length 92) for shaders
<bdbdbd> data/shaders/worldshader.vert, and data/shaders/worldshader.frag:
<bdbdbd> Vertex info
<bdbdbd> -----------
<bdbdbd> 0(137) : error C1013: function "main" is already defined at 0(130)
<bdbdbd> ShaderProgram:Link: Failed to link program.

Can anyone tell me why it would throw this error in the linker log?? OF COURSE there are two main() functions, it's a friggin vert/frag combo

The reason I am posting here is because I'm comparing glew to a raw implementation and trying to figure out why it would be different.

Discussion

  • Nigel Stewart

    Nigel Stewart - 2010-12-23

    What's the content of the vertex shader?

     
  • Nigel Stewart

    Nigel Stewart - 2010-12-28

    Probably going to need more information on this.

     
  • Nigel Stewart

    Nigel Stewart - 2011-08-02

    I suggest bringing this to one of the GLEW mailing lists, if it's still an issue.

     
  • Nigel Stewart

    Nigel Stewart - 2013-08-23
    • status: pending --> closed
    • Group: --> v1.0_(example)
     
  • Nigel Stewart

    Nigel Stewart - 2013-12-09
    • Group: v1.0_(example) --> 1.10.0
     

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:





No, thanks