#180 instalation process induces ABI incompatibility

Future
open
nobody
None
3
2014-08-12
2011-12-23
galtgendo
No

I'm not sure how ABI compatible are GLEW releases, but the default install induces a forced ABI incompatibility.
I described the problem here: https://bugs.gentoo.org/show_bug.cgi?id=385631.

Discussion

  • Nigel Stewart

    Nigel Stewart - 2012-01-11

    The working assumption for GLEW version numbering is that GLEW 1.7.(x+n) ought to be binary compatible with GLEW 1.7.x, where n>0. In other words, when there is a breaking ABI change, we increment the minor version, say from 1.7.x to 1.8.0

    So it ought to be fine for a GLEW 1.7 symlink to point to 1.7.0, or 1.7.1, ... etc

    • Nigel
     
  • Nigel Stewart

    Nigel Stewart - 2013-08-23
    • Group: --> 1.11.0
     
  • Nigel Stewart

    Nigel Stewart - 2014-08-12
    • Group: 1.11.0 --> Future
     

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:

JavaScript is required for this form.





No, thanks