#105 libgdk_imlib.so.1, needed by /usr/lib/libgnomeui.so

important
closed-rejected
nobody
GUI (37)
5
2004-01-06
2004-01-05
No

while compiling glame (ui) it spits out this message:
/usr/bin/ld: warning: libgdk_imlib.so.1, needed by
/usr/lib/libgnomeui.so, may
conflict with libgdk_imlib.so.2

It seems that libgnomeui was compiled with
libgdk_imlib.so.1, so ldd says and
ofcourse everything that's linked to libgnomeui.so is
using this library

When i run glame it says

emanoil@bendida:~/tmp$ /opt/glame/bin/glame
loading /opt/glame/share/glame/scripts/glame.scm
/opt/glame/share/glame/scripts/resample.scm: uncaught
throw to glame-error: ()
/opt/glame/share/glame/scripts/bassboost.scm: uncaught
throw to glame-error:
()
free_filter: GCing 0x8151160 ((null))
free_filter: GCing 0x8151348 ((null))
/opt/glame/share/glame/scripts/write_mp3.scm: uncaught
throw to glame-error:
()
loading /home/emanoil/.glamerc
update_preferences: Preferences:
Swapfile directory /home/emanoil/.glameswap
Undo stack depth is 5
Audio input plugin oss_audio_in, device
"plughw:0,0", rate 44100
Audio output plugin oss_audio_out, device
"plughw:0,0"
GLAME_WBUFSIZE 1024
Popup timeout is 200ms
Mac mode is off
gui_main: path: /home/emanoil/.glameswap
libpng warning: Application was compiled with png.h
from libpng-1.2.1
libpng warning: Application is running with png.c from
libpng-1.0.12
libpng error: Incompatible libpng version in
application and library
gdk_imlib ERROR: Cannot load image:
/usr/share/pixmaps/gnome-error.png
All fallbacks failed.
See /usr/share/doc/gdk-imlib1/README.fallback.
libpng warning: Application was compiled with png.h
from libpng-1.2.1
libpng warning: Application is running with png.c from
libpng-1.0.12
libpng error: Incompatible libpng version in
application and library
gdk_imlib ERROR: Cannot load image:
/usr/share/pixmaps/gnome-default-dlg.png
All fallbacks failed.
See /usr/share/doc/gdk-imlib1/README.fallback.
gpsm_sync: 87 bytes xml
<?xml version="1.0"?>
<swapfile>
<group label="test" hpos="0" vpos="0"/>
</swapfile>

cluster_cleanup: SWFS_CLUSTER Statistics: 16 gets, 14
lru hits, 2 misses
cluster_cleanup: 1 meta reads, 1 meta writes, 1
data creates

I have libpng3-dev installed and the libraries for libpng2.
I cannot install libpng2-dev because of dependency
problems.

Even if I compile and install libpng it won't help
because I can not put it in
/usr/lib, where gdk_imlib1 is looking for it

What should I do?

I am linguist and I need a good audio processing system
and I am a hoby
programmer (scripter) don't know C that well.

Discussion

  • Emanoil Kotsev

    Emanoil Kotsev - 2004-01-05

    Logged In: YES
    user_id=944112

    I downloaded the CVS version and it's using gnome2 - I like
    it it is working now, though there were some other bugs I
    had to fix in order to compile

     
  • Richard Guenther

    Logged In: YES
    user_id=7575

    Maybe you should just use the debian package then. You
    really need to use the libpng imlib was build with.

    Richard.

     
  • Richard Guenther

    • status: open --> closed-rejected
     
  • Emanoil Kotsev

    Emanoil Kotsev - 2004-01-06

    Logged In: YES
    user_id=944112

    You can close this as I mentioned before I fixed the problem
    using the latest avialable CVS version, that is using gnome-2.
    I think the 1.0.1 version was using gnome 1.2 or 1.4 and the
    old libgdk_imlib.so.1.9.14 that was linked to libpng2. some
    other libraries were linked to libgdk_imlib.so.2.0.0 and
    that was the problem.

    With the gnome-2 support all those problems were solved, as
    I have most of the gnome-2 libraries installed.

    Writing this I hope that it would be useful to somebody else.

    Thank you for the response richi!

     

Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:





No, thanks