#1 gdk_string_width probelm

2.0
closed
nobody
None
5
2014-06-15
2010-10-21
Knefas
No

Hi Erik,

gdk_string_width in gkfreq is used incorrectly (pre PangoFont migration), and it causes warnings during the build and possibly other errors. The fix is described in [1], and it's simply to replace the call to gdk_string_width with gkrellm_gdk_string_width.

Due to this problem this great plugin which I have been using for many years is being removed from the Gentoo repository [2], therefore I'd be grateful if you could put out a new version with the gdk_string_width problem fixed.

Thanks in advance and thanks for maintaining gkfreq alive!

Pietro

[1] http://www.mirrorservice.org/sites/members.dslextreme.com/users/billw/gkrellm/plugins2-reference.html
[2] http://bugs.gentoo.org/show_bug.cgi?id=339908

Discussion

  • Erik Kjellson

    Erik Kjellson - 2013-03-02

    This is now fixed in version 2.1.

     
  • Erik Kjellson

    Erik Kjellson - 2013-03-02
    • status: open --> closed
    • milestone: -->
     
  • Erik Kjellson

    Erik Kjellson - 2014-06-15
    • Group: --> 2.0
     

Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:

JavaScript is required for this form.





No, thanks