Using Xquartz and Gimp

Help
2011-11-11
2013-05-15
  • Allen Hitoto

    Allen Hitoto - 2011-11-11

    So after running around on the internet for a while I have some questions.
    Since I'm using a Mac with 10.6.8, I experience an error I have to download X11 from a disk if I ever lose it (Which I have recently done) and so I'm resorting to a substitute(Xquartz). I've downloaded both xquartz and gimp. I've put gimp into my applications folder and when I try to launch it, Xquartz doesn't even open and the gimp applications starts bouncing but disappears on my dock. I would greatly appreciate any help on this topic.

     
  • Simone Karin Lehmann

    BTW

    XQuartz is _not_ a substitue for Apple's X11. Its' a stand alone program, which other application have to use explicitly. You can have both X11 versions on your Snow Leopard system.

    So, please, do _not_ use XQuartz. I've choosen Apple's X11, so you need Apple's X11. That's it. And there is no chance to get around this.

     
  • Dominik Reichardt

    Curiosly I never had any problem running Gimp (from Gimp on OS X) with Xquartz. I'm now almost three years on OS X and ever since I switched I used this Gimp and Xquartz with most up to date OS X. No problems at all.

    So why *does* it work for me even though you state it doesn't? Maybe because I also have MacPorts installed?

     
  • Anonymous - 2011-12-11

    Dominus, Very happy to read your input, XQuartz v. Mac X. If it works for you Great! I can offer no ideas on why it does, but…….
    Mac ports is something I"ll be exploring for using 'Darktable' in the near future. I am , very happily, using Gimp with Mac's version of 'X'.

     
  • Simone Karin Lehmann

    @dominus

    here's why it has _absoluty_ nothing to do wirth XQuartz why you could run GIMP on OS X packages. You've already installed Apple's X11 on your system and XQuartz too. So you have two sets of X11 librariers and tools, each are completly independent of the other one.

    So here's why you need Apple's X11.

    This is for Snow Leopard:

    1) If you compile an application that uses libraries of other pacckages (GIMP uses X11 librariers) these other librariers are referenced by their full path name.
    2) I decided to use Apple's X11 librariers at compile time
    3) Apple's X11 librariers are located in /usr/X11/lib. Just open Terminal.app and type 'cd /usr/X11/lib' and then 'ls' and you'll see those libs.
    4) GIMP uses these librariers in /usr/X11/lib _and_ the those libraries need to be the latest version Apple provides via Software Update
    5) XQuartz libraries are installed in subdirectories under /opt. … just use Terminal.app to proove this.
    6) Because GIMP is linked against libs in /usr/X11/lib, GIMP do __not_ use XQuartz libraries.

    Now why i'm so hostile against XQuartz:

    First, on Snow Loepard Apple's X11 is installed by default. Unfortunately some people explicitly disable it during installation. If they now try to start GIMP, those libraries aren't present on their Mac and GIMP won't launch- Now, if they will install XQaurtz instead of Apple's X11,  nothing will change. Libs in /usr/X11/lib are still not present. AND, installing Apple's X11 won't work any longer, since the version of XQaurtz is newer than Apple's X11. Running software update won't work too.

    Second if people have installed Apple's X11 from their installtion DVD and did _not_ run Software Update, GIMP won't start. If they now install XQaurtz instead of running Software Update, GIMPO still doesn't start, but now they can't update the already installed Apple X11, because XQaurtz is newer and this confuses SU…

    So, it's absolutely of no use to install XQuartz unless you have some application which are linked against the libraries in /opt.

    BTW, MacPorts applications - and therefor the MacPorts's version of XQaurtz too, are installed under /opt/local. If you've installed MacPort's X11 to, you have three sets of X11 libraries and tools on your system, and, most of all, GIMP still needs Apple's X11 to work.

    If you don't trust me, then just delete /usr/X11 and see if GIMP will still work. I'll promise, it won't. But be warned. After deleting /usr/X11 there's no easy way to restore it. So if you're sure, that XQuartz is the reason why GIMP is working, well, then of course you can delete /usr/X11 …..

    So for the very last time:

    GIMP on OS X needs Apple's X11.

    -skl

     
  • Dominik Reichardt

    I can see why it works now, thanks. I can see that on starting Gimp it loads Xquartz but uses libs in /usr/x11.

    I cannot quite see why you are so hostile though. Yes, it is quite a mess but a mess that can't be untangled without ignoring newer x11 versions at all. As long as people recommend to use xquartz over x11 that mess won't go away. And xquartz will also not just go away…

    You *could* do it as Crossover does and include X11 in the package (and if one figures it out, duplicate how they do it that no x11 needs to start alongside - maybe that's just how it works when it comes bundled).

     
  • malibunerd

    malibunerd - 2012-07-01

    I am having a similar problem. I downloaded Gimp for my Macbook which runs on Snow Leopard and it did not allow me to access the app until I downloaded Xquartz. Even though I had heard that it does not function and that I must use X11 to open, I couldn't access the app any other way so I downloaded Xquartz. After it finished downloading, I attempted to open Gimp but it did not work. The Gimp logo would bounce on the dock and moments later the X11 logo would appear on the dock as well. Neither would open. Xquartz does absolutely nothing and I unfortunately cannot re-download X11 since I no longer own my Snow Leopard installation CD. Why is this happening and is there any way to fix this without reinstalling X11? Thank you.

     
  • Simone Karin Lehmann

    If you want to use GIMP 2.8.0 or higher on SnowLeopard, you need to install XQuartz. Apple's X11 has a bug which won't run with GIMP 2.8.0

    So,

    GIMP 2.6.x needs Apple's X11

    GIMP 2.8.x needs XQuartz.

    After installing XQuart, please log out and log in again, to make XQuartz start by default.

    You can _not_ mix it. Soory folks, there's nothing I can do to make your life easier…

    -skl

     
  • Anonymous - 2012-07-09

    Installed 2.6 on my Snow leopard and it worked fine last week. Today it won;t load. The Apple X11 pops up in the dock and soon disappears. Tried deleting and reloading but nothing works. Does anyone know how to remedy this?

     

Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:





No, thanks