Gimp 2.6.11 crashes on startup in Leopard

Help
2011-01-04
2013-05-15
  • Hal Parfitt-Murray

    I have deleted and re-installed x11 from my Leopard disc (update disc only). Ran software update to get latest version - it tells me there is no new software. I get this error log when I try to run GIMP:

    Process:         gimp-2.6
    Path:            /tmp/skl/Gimp.app/Contents/Resources/bin/gimp-2.6
    Identifier:      gimp-2.6
    Version:         ??? (???)
    Code Type:       X86 (Native)
    Parent Process:  sh

    Interval Since Last Report:          783 sec
    Crashes Since Last Report:           1
    Per-App Interval Since Last Report:  0 sec
    Per-App Crashes Since Last Report:   1

    Date/Time:       2011-01-04 10:06:32.105 +0100
    OS Version:      Mac OS X 10.5.8 (9L31a)
    Report Version:  6
    Anonymous UUID:  CB5DA8FD-EED9-4809-AD42-41AEE96077DB

    Exception Type:  EXC_BREAKPOINT (SIGTRAP)
    Exception Codes: 0x0000000000000002, 0x0000000000000000
    Crashed Thread:  0

    Dyld Error Message:
      Library not loaded: /usr/X11/lib/libXdamage.1.dylib
      Referenced from: /tmp/skl/Gimp.app/Contents/Resources/lib/libgtk-x11-2.0.0.dylib
      Reason: Incompatible library version: libgtk-x11-2.0.0.dylib requires version 3.0.0 or later, but libXdamage.1.dylib provides version 2.0.0

    Any help would be appreciated.
    Hal

     
  • Simone Karin Lehmann

    Please check your X11 version and your GIMP version. X11 has to be 2.1.6. And you need GIMP 2.6.11 for Leopard. The SnowLeopard version won't run.

     
  • Hal Parfitt-Murray

    x11 is version 2.1.6 and Gimp is 2.6.11 for Leopard.

     
  • Simone Karin Lehmann

    x11 is version 2.1.6

    No, because…

    Reason: Incompatible library version: libgtk-x11-2.0.0.dylib requires version 3.0.0 or later, but libXdamage.1.dylib provides version 2.0.0

    … X11 version 2.1.6 has libXdamage.1.dylib version 3.0.0.

    You've only installed an old X11 version so update your X11 (either via Software update or via Mac OS X Combo Update for 10.5.8)

     
  • Hal Parfitt-Murray


    Software update doesn't touch it - it says it's version 2.1.6 on the info screen. I'm already running Combo Update 10.5.8. What should I do?

     
  • Simone Karin Lehmann

    I have deleted and re-installed x11 from my Leopard disc

    how did you deleted X11? You can't delete X11 by putting 'Applications/Utilities/X11.app' into the Trash. This is only a launcher app. X11 is a set of libraries and tools and is placed in some directories on your harddrive. So it seems to me, that you somehow deleted something else than just the launcher app in 'Applications/Utilities'. Try to reinstall X11 from the installation DVD and rerun Software Update or Combo Update. Or try to find some X11 specific forum or mailing list and ask those guys. Maybe http://lists.apple.com/mailman/listinfo/x11-users could help.

     

Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:

JavaScript is required for this form.





No, thanks